Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

macro incolla formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

macro incolla formula

Postdi matzap » 10/02/15 17:28

vorrei inserire tramite macro questa formula in una cella :
=SE(Z18<>0;Z18;" ")
ho provato con:
ActiveCell.FormulaR1C1 = "=SE(Z18<>0;Z18;" ")"
ma non mi inserisce nulla.
potete aiutarmi?
Ciao e grazie
excel 2010
matzap
Utente Senior
 
Post: 227
Iscritto il: 16/04/13 08:27

Sponsor
 

Re: macro incolla formula

Postdi ricky53 » 10/02/15 17:38

Ciao,
prova in questo modo
Codice: Seleziona tutto
ActiveCell.FormulaLocal = "=SE(Z18<>0;Z18;"" "")"



Attenzione che "ActiveCell" può creare problemi è meglio scrivere l'indirizzo della cella in cui scrivere la formula, per esempio
Codice: Seleziona tutto
Range("AA18").FormulaLocal = "=SE(Z18<>0;Z18;"" "")"


Ho scelto la cella "AA18" come esempio, inserisci la tua celle effettiva
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: macro incolla formula

Postdi matzap » 11/02/15 09:00

Grazie, funzionano entrambe!
ciao
excel 2010
matzap
Utente Senior
 
Post: 227
Iscritto il: 16/04/13 08:27

Re: macro incolla formula

Postdi ricky53 » 11/02/15 09:26

Ciao,
bene.
Alla prossima e buon proseguimento.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "macro incolla formula":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti