Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula per mescolare dei dati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: Formula per mescolare dei dati

Postdi Anthony47 » 10/02/15 02:49

Credo che Sasyjoe abbia manifestato in modo esagerato il suo disappunto...
Lo spirito del forum e' che si e' liberi di chiedere, e chi e' in grado di rispondere (per conoscenza, per tempo, per interesse o per altri insindacabili preferenze) risponde.
Personalmente ho abbandonato la discussione perche' non ho capito la domanda (forse perche' alle domande arrivava "sempre la stessa risposta"), e comunque non ho ancora capito perche', sapendo il valore che deve essere inserito, si insiste nel "controllare" che il valore venga scritto bene e non venga invece scritto direttamente tramite una formula; in ogni caso non conosco gli algoritmi di crittografia bidirezionali, per cui non sarei qualificato per rispondere.

Grazie a Ricky per averci provato.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Sponsor
 

Re: Formula per mescolare dei dati

Postdi Sasyjoe » 10/02/15 08:01

Vabene. Grazie a tutti
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Formula per mescolare dei dati

Postdi Flash30005 » 10/02/15 13:40

Ultimo tentativo dopodiché andrò in vacanza :D

Inserisci in A2 il numero (intero o decimale che sia)
in B" inerisci la formula che "cripta"
Codice: Seleziona tutto
=DECIMALE.HEX(INT(A2);10)&SE(VAL.ERRORE(TROVA(",";A2;1))=FALSO;"Z";"")&DECIMALE.HEX((A2-INT(A2))*100;5)

In C2 quella che decripta
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("Z";B2;1))=VERO;HEX.DECIMALE(B2);HEX.DECIMALE(STRINGA.ESTRAI(B2;1;10))&","&HEX.DECIMALE(STRINGA.ESTRAI(B2;12;17)))

Come vedi Ho usato la funzione Decimale.Hex e viceversa ma puoi usare qualsiasi altra funzione esempio Oct etc
ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formula per mescolare dei dati

Postdi Sasyjoe » 10/02/15 19:21

Geniale.

Non la conoscevo.

La ho corretta in quanto funzionava solo con numeri interi e non funzionava senza decimali. Inoltre ho ridotto lunghezza. Mi interessa solo per numeri inferiori ad 1.000.000,00Euro.

Risultato:

A2 Numero inferiore ad un 1.000.000,00

B2 Codifico:
=DECIMALE.HEX(INT(A2);5)&SE(VAL.ERRORE(TROVA(",";A2;1))=FALSO;"Z"&DECIMALE.HEX((A2-INT(A2))*100;2);"")


C2 Decodifico:
=SE(VAL.ERRORE(TROVA("Z";B2;1))=VERO;HEX.DECIMALE(B2);HEX.DECIMALE(STRINGA.ESTRAI(B2;1;5))&","&HEX.DECIMALE(STRINGA.ESTRAI(B2;7;14)))+0


Grazie mille. Sei grande.

Grazie anche a rikcy ed antonhy per l'interessamento.

Ciao
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Formula per mescolare dei dati

Postdi Flash30005 » 10/02/15 23:35

A questo punto la si può rendere ancora più semplice ma più complicata a risalire al numero con questa formula per criptare
Codice: Seleziona tutto
=DECIMALE.HEX(DECIMALE.OCT(A2*100;10);10)

e questa per decriptare
Codice: Seleziona tutto
=OCT.DECIMALE(HEX.DECIMALE(B2))/100

In pratica moltiplichi per 100* il numero che se intero diventa con 2 zeri in più
se invece decimale (con 2 cifre) diventa intero
applichi prima la funzione Dec.Oct e di quest il dec.Hex
alla fine fai l'inverso ;)

*) Il moltiplicatore 100 può essere qualsiasi altro numero superiore a 100 ;)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formula per mescolare dei dati

Postdi Sasyjoe » 11/02/15 13:31

Grazie.

Geniale!
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Formula per mescolare dei dati

Postdi Flash30005 » 12/02/15 15:01

Sasyjoe ha scritto:Geniale!


Io? Ma scherzi?
se lo fossi avrei capito anche l'utilizzo ma... non ho proprio la minima idea :neutral:

mi faresti un esempio pratico?

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "Formula per mescolare dei dati":


Chi c’è in linea

Visitano il forum: albval, Zer0Kelvin e 17 ospiti