Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca.vert con riferimento a fogli variabili

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca.vert con riferimento a fogli variabili

Postdi Lyke73 » 30/12/14 13:05

Ciao a tutti, sto creando un database sulla serie a di calcio. Con questo codice
Codice: Seleziona tutto
Dim dat As String
Sheets.Add
ActiveSheet.Name = Sheets("report").Range("A1").Text
dat = Sheets("report").Range("A1").Text
Sheets(dat).Select

creo un nuovo campionato il cui foglio viene identificato come Sheets(dat) e che userò come riferimento nelle macro di inserimento dati nel campionato attuale.
Il mio quesito è: come posso scrivere la formula cerca.vert usando come riferimento i dati del foglio dat ?
ES.
=CERCA.VERT($K4;'2013-2014'!$B$3:$I$382;4;FALSO)
vorrei invece
=CERCA.VERT($K4;'sheets dat!$B$3:$I$382;4;FALSO)
Grazie a tutti !
excel 2007
Lyke73
Utente Junior
 
Post: 21
Iscritto il: 27/10/14 11:07

Sponsor
 

Re: cerca.vert con riferimento a fogli variabili

Postdi alfrimpa » 30/12/14 14:35

Ciao

Potresti scrivere

Codice: Seleziona tutto
var = Application.WorksheetFunction.VLookup(Range("$K$4").Value, Sheets("sheets dat").Range("$B$3:$I$382"), 4, FALSE)



ovviamente si possono definire anche variabili oggetto ed utilizzare quelle come parametri della funzione VLookup (cerca.vert)

Spero di aver compreso bene il tuo quesito

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: cerca.vert con riferimento a fogli variabili

Postdi Lyke73 » 30/12/14 14:37

Si hai compreso bene e ti ringrazio, la proverò !
Grazie e buon anno a tutti !
excel 2007
Lyke73
Utente Junior
 
Post: 21
Iscritto il: 27/10/14 11:07

Re: cerca.vert con riferimento a fogli variabili

Postdi Lyke73 » 31/12/14 12:50

....l'ho fatta troppo semplice....ho provato a scrivere questo codice
Codice: Seleziona tutto
Sub cerca_vert()
Dim dat As String
dat = Sheets("report").Range("A1").Text
Sheets(dat).Activate
Var = Application.WorksheetFunction.VLookup(Range("$K$4").Value, Sheets("sheets dat").Range("$B$3:$I$382"), 4, False)
Sheets("storia").Select
Range("l4").Select
End Sub

che mi da subito errore sulla riga Var = " indice non incluso nell'intervallo"
Vorrei che la formula venisse inserita nel foglio "storia", cella "L4".
MI aiuti....grazie!
excel 2007
Lyke73
Utente Junior
 
Post: 21
Iscritto il: 27/10/14 11:07

Re: cerca.vert con riferimento a fogli variabili

Postdi alfrimpa » 31/12/14 15:56

Ciao Lyke73

Non entro nel merito del codice che hai postato (mi sembra che ci sia qualche errore).

L'errore che ti da il codice potrebbe essere dovuto al fatto che non trova K4 nella matrice di ricerca (sei sicuro che ci sia?).

Poi non ho capito la cella L4 del foglio storia deve contenere il valore della variabile var (e quindi del cerca.vert in VBA ) oppure vuoi che in L4 venga inserita la formula =cerca.vert(etc.......)?

In ogni caso forse è meglio che alleghi un file di esempio corredato di spiegazioni e dove inserisci manualmente i risultati che vuoi ottenere.

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli


Torna a Applicazioni Office Windows


Topic correlati a "cerca.vert con riferimento a fogli variabili":


Chi c’è in linea

Visitano il forum: alfrimpa e 20 ospiti