Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] prospetto calcolo ore

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] prospetto calcolo ore

Postdi grankio » 12/12/14 22:04

ciao a tutti ho un foglio di calcolo che mi servirebbe per calcolare delle ore di straordinario,solo che non riesco a riuscire con le formule, in pratica il foglio dovrebbe fare il seguente calcolo
Colonna A: anno e mese e qui ci sono ;)
Colonna B: il numero di settimane 1,2,3 ecc.. ;
Colonna C: il numero di ore che sono 21 per settimana in pratica vorrei che inserendo i dati nella colonna B mi moltiplicasse in automatico per 21 cioe il numero di ore straordinarie per ciascuna settimana io ho provato a fare =SE (B4>0; C4=B4*21) ma mi da sempre 0;
Colonna D: il numero di giorni festivi che mi corrisponde a 3,5 ore;
Nella colonna E: le ore utili che sono date dalle ore della colonna C meno il numero di festivi quindi se ho un festivo 3,5 ore se sono 2 festivi 7 ore e cosi via;
Nella colonna F: delle ore risultanti utili (colonna E) le prime 8 vorrei che automaticamente finissero qui, le eventuali successive se ne rimangono nella colonna G.

vi allego il file, e fattibile con le formule o devo creare più colonne e fargli fare i passaggi manualmente?
http://www.filedropper.com/orecalcolo
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Sponsor
 

Re: [Excel] prospetto calcolo ore

Postdi grankio » 12/12/14 22:23

scusate il doppio post ma non mi fa editare il messaggio, ho risolto per la colonna C in questo modo : =SE(B4>0;B4*21) solo che vorrei fare in modo che nelle celle in cui non c e valore non compaia la scritta FALSO, per il resto del calcolo non ho proprio idea potrei sempre usare il SE?
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 12/12/14 23:44

In C4, E4, F4 e G4 rispettivamente:
Codice: Seleziona tutto
=SE(B4>0;B4*21;0)

Codice: Seleziona tutto
=C4-D4*3,5

Codice: Seleziona tutto
=SE(E4>8;8;E4)

Codice: Seleziona tutto
=SE(E4>8;8;E4)

Edit by Anthony: l' ultima formula pubblicata e' errata; vedi correzione nel mio next messaggio
Poi copia le formule sulle righe sottostanti.
Suggerisco di formattare queste celle con lo "stile separatore" (quello che in genere corrisponde all' icona con "000"), in modo da non visualizzare eventuali 0.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] prospetto calcolo ore

Postdi grankio » 13/12/14 09:54

buongiorno prima di tutto grazie, xo la notte porta consiglio e la situazione si è complicata :) , l'ultima formula non va perché dovrebbe mettere in g4 solo le ore che superano le 8.
cmq vi pongo il mio nuovo problema, premesso che le ore non sono 21 ma 11 e che dividendo per sei giorni lavorativi ho 1,83 ore in più al giorno fino alla colonna E il calcolo andrebbe bene, il problema sono le ultime due colonne in pratica le ore settimanali eccedenti la 40 e fino alla 48 si maggiorano del 27%, dalla 48 in poi si maggiorano del 30% allo stato attuale mi mette nella colonna F solo 8 ore ma dovrebbe invece tenere conto anche delle settimane e suddividere le ore in base ad esse(altrimenti si maggiorerebbero solo 8 ore al 27 ed il restante al 30 e sarebbe sbagliato) quindi nel nuovo foglio che ora allego, tenendo conto di 4 settimane, togliendo un festivo in cui non c e orario extra ho 42,17 ore quindi io so che in quel mese 3 settimane sono piene e quindi le prime 8 ore a settimana vanno nella colonna F le eccedenti nella G, la 4 settimana c'e stato un festivo (potrebbero essere 2-3 e le settimane potrebbero essere minori) di conseguenza 8 ore vanno sempre in colonna F e la restante 1,17 nella G.
http://www.filedropper.com/orecalcolo_2

Ps. spero si capisca la spiegazione del problema
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 13/12/14 12:14

La formula in G4 doveva essere
Codice: Seleziona tutto
=SE(E4>8;E4-F4;0)
(e non quella gia' presente in F4)

Ps. spero si capisca la spiegazione del problema
Ti devo deludere... Della nuova descrizione ho capito poco o niente, complice anche una punteggiatura "alquanto scarna" e il fatto che assumi che tutti noi abbiamo il problema di riprendere le ore lavorate nel 1986 e quindi capiamo al volo...
Dovresti chiarire quali sono i dati di partenza e quali dati vorresti calcolare, possibilmente scendendo al linguaggio excel.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] prospetto calcolo ore

Postdi grankio » 13/12/14 12:56

ok provo a spiegare meglio,in una settimana considera 6 giorni lavorativi per un totale di 40 ore, in ogni settimana vengono comunque fatte 11 ore in più ad esclusione di eventuali settimane in cui ci sono giorni festivi che andrei a togliere (ora 1,83),ed otterrei le ore complessive fatte in più in quelle settimane.
di queste ore in più che si fanno a settimana, al netto di eventuali festivi, settimanalmente le prime 8 devono finire nella colonna al 27%, e le restanti se ci sono nella colonna 30%, a me interessa che il foglio riesca a fare una distinzione in base alle settimane, perché allo stato attuale dalle ore complessive ne mette 8 nella colonna al 27% ed il restante al 30% il che è sbagliato.
non considerare l'anno potrebbe essere anche 2000 o 1900
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi grankio » 13/12/14 14:19

ho fatto un altro foglio forse cosi e più semplice
Colonna A: anno e mese
Colonne dalla B alla F; le varie settimane del mese dove se io metto una L lui ha lavorato e quindi equivale ad 11 ore, se metto 1 vuol dire che in quella settimana c e stato un festivo e quindi sara uguale alle 11 ore meno 1,83, se metto un 2 sara uguale ad 11 meno 1,83*2 e cosi via,se non metto niente non ha lavorato quindi 0:
Colonna G: ci metterei il totale di ore quindi 11* il numero di settimane;
Colonne dalla H alla K: il risultato di quello che c e scritto nelle colonne da B a F se io metto una L lui ha lavorato quella settimana e quindi equivale ad 11 ore in corrispondenza della stessa settimana, se metto 1 vuol dire che in quella settimana c e stato un festivo e quindi sara uguale alle 11 ore meno 1,83, se metto un 2 sara uguale ad 11 meno 1,83*2 e cosi via,se non ho messo niente non ha lavorato quindi 0:
Colonna M: la somma delle ore presenti nelle colonne prima descritte;
Colonna N: in base ai dati presenti nelle colonne dalla H alla K qui devono finire le prime 8 ore di ciascuna settimana
Colonna O: le ore superiori all'ottava se ci sono

unico problema non so come comportarmi se in un mese lavorasse ad esempio solo 2-3 giorni
cmq credo ora sia più comprensibile ma più complicato,allego il foglio http://www.filedropper.com/calcoloore2
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 14/12/14 22:39

Non sapendo a cosa serve il calcolo intervengo solo per suggerire possibili formule, con l' handicap che non ho capito quale e' l' oraro di lavoro da considerare (11 ore? 40+11?)
Potresti usare in H4 la formula
Codice: Seleziona tutto
=(OreSettimanali)*CONTA.VALORI(B4)- SE(VAL.NUMERO(B4);(OreDaSottrarrePerOgnoGiornoFestivo)*VALORE(B4);0)
Poi copi H4 nelle colonne adiacenti

In G4:
Codice: Seleziona tutto
=SOMMA(H4:K4)

In M4:
Codice: Seleziona tutto
=G4

In N4:
Codice: Seleziona tutto
=CONTA.SE(H4:K4;">=8")*8

In O4:
Codice: Seleziona tutto
=SOMMA(H4:K4)-N4


unico problema non so come comportarmi se in un mese lavorasse ad esempio solo 2-3 giorni
Se non lo sai tu, figurati noi (anche se avevo capito che c' era piu' di un unico problema)!

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] prospetto calcolo ore

Postdi grankio » 14/12/14 22:46

ciao ho provato a fare cosi
=SE(C5="";0;SE(C5=1;SOMMA(11-1,83);SE(C5=2;SOMMA(11-(2*1,83))))) e fino a qui va bene,
ma se continuo la formula mi da sempre falso anche se le condizioni successive sono vere
=SE(C5="";0;SE(C5=1;SOMMA(11-1,83);SE(C5=2;SOMMA(11-(2*1,83);SE(C5=3;SOMMA(11-(3*1,83)))))))
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi grankio » 14/12/14 23:04

ciao grazie mille non capisco come hai fatto, dato che non vedo come hai scritto le condizioni ma la prima parte funziona perfettamente, unico problema sono le ultime due colonne delle quali non funziona la formula,in pratica per ogni settimana (colonne H alla K) la formula dovrebbe controllare singolarmente, e le sole ore dalla prima alla 8 sommarle nella colonna al 27%, in quella al 30% sommare le sole ore o frazioni di ore superiore all'ottava.
TI allego il foglio come esempio, se io metto una L lui in automatico mi da per quella settimana 11 ore e le divide in modo giusto le prime 8 nella casella al 27 e le altre 3 al 30 (lo stesso se metto 1 ), se pero vado ad aumentare i giorni da detrarre ad es. 2-3-4 mette tutto nella casella al 30 mentre dovrebbero andare in quella al 27

http://www.filedropper.com/orecalcolo_3

Cmq di nuovo grazie mille ci sto perdendo la testa da stamattina
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 15/12/14 13:18

In effetti la formula per N4 invertiva la logica tra N e O; in N4 usa invece
Codice: Seleziona tutto
=MIN(8;M4)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] prospetto calcolo ore

Postdi grankio » 15/12/14 19:10

ciao, prtroppo non funziona , continua a mettermi nella colonna N solo 8 ,mentre a me servirebbe che la colonna N prelevasse dalle colonne dalle colonne da H ad L solo i numeri ce vanno da 0 ad un massimo di 8, come puoi vedere dal foglio, nelle prime due righe gialle, in nessuna settimana vengono superate le 8 ore quindi andrebbe tutto sommato nella colonna N, mentre, le prime 7.3 le mette al posto giusto le ore delle altre settimane non le aggiunge,il discorso invece cambia e la formula funziona nelle righe in arancione http://www.filedropper.com/orecalcolo_4
ho provato a fare cosi:

=MIN(8;H4);MIN(8;I4);MIN(8;J4);MIN(8;K4)

ma ovviamente non funziona :) , puo essere che sono una serie di condizioni che Excel non supporta con le sue funzioni?
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 15/12/14 23:40

Mi sono impegnato un po' di piu', facendo aaanche il collaudo sul file di esempio....
In N4:
Codice: Seleziona tutto
=SOMMA(SE(H4:K4>=8;8;H4:K4))
da confermare con Contr-Maiusc-Enter, non il solo Enter.

Oppure, partendo dalla tua formula dalla sintassi un po' avventurosa:
Codice: Seleziona tutto
=MIN(8;H4)+MIN(8;I4)+MIN(8;J4)+MIN(8;K4)

Che sia la volta buona?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] prospetto calcolo ore

Postdi grankio » 16/12/14 13:09

perfetto funzionano entrambe, sei un grande grazie, in italiano cosa significa la seconda? Minimo 8 da H4 + minimo 8 da I4 ?
Windows 8
Office 2007-2010
grankio
Utente Junior
 
Post: 67
Iscritto il: 02/02/14 14:27

Re: [Excel] prospetto calcolo ore

Postdi Anthony47 » 19/12/14 01:05

in italiano cosa significa la seconda? Minimo 8 da H4 + minimo 8 da I4 ?
1) Guarda che questa l' hai scritta tu, io l'ho solo "migliorata"...
2) Questo e' un forum che tratta di Excel, quindi posso dirti solo che in linguaggio excel la formula prende fino a 8 ore di H4, le somma con fino a 8 ore di I4, le somma etc etc. Per la lingua italiana devi provare su treccani.it o accademiadellacrusca.it

Alla prossima!
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] prospetto calcolo ore":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti