Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Cerca ed estrai

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Cerca ed estrai

Postdi Zetsu » 05/12/14 19:36

Buonasera, qui sempre Zetsu.

Ho nel foglio1 excel una serie di colonne , dove ho dei valori, come in questo esempio

A B C D E

-400 -360 12 1 14

********************
40 80 3 4 5

80 120 2 1 6

120 160 0 0 0
********************
360 400 1 0 1

(gli asterischi indicano tutta una serie di righe che per comodità non scrivo, anche perché è un esempio)

Nel foglio2 ho una colonna con dei dati, ad esempio

A

41

119

144

Quello che vorrei è che mi restituisse accanto ai valori che ho nel foglio2 i valori del foglio1 se questi sono compresi nell' intervallo

in questo caso vorrei un risultato di questo tipo nel Foglio2

A B C D

41 3 4 5

119 2 1 6

144 0 0 0

Seguendo le direttive del sito office.microsoft, con un cerca.vert con valore approssimativo dovrei trovare quel che voglio..

invece non va proprio, mi da valori che non so proprio da dove li pesca....

qualche idea?
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Sponsor
 

Re: [Excel] Cerca ed estrai

Postdi ricky53 » 05/12/14 21:27

ciao, puoi inviare la formula che non fornisce i risultati attesi ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Cerca ed estrai

Postdi Anthony47 » 05/12/14 23:48

Gradita la formula usata, come gia' chiesto da Ricky.
Aggiungo che, per funzionare, l' elenco deve essere rigorosamente in ordine crescente, fino alla fine.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Cerca ed estrai

Postdi Zetsu » 06/12/14 15:19

=CERCA.VERT(A9;$F$6:$I$125;2;VERO)

Formula che inserisco

a9 = valore da cercare nella matrice

F6:I125 = matrice tabella

2 = seconda colonna, quella da dove deve pescare

vero = cerca il valore più vicino.

I valori sono in ordine crescente , da un numero -1.000 a +1.000 ad esempio...

scusate , ero convinto di averla copiata qui invece l'avevo copiata in un altro foglio excel

Adattandola all' esempio che avevo messo sopra, io vorrei dirgli " cerca nella colonna il valore più vicino e più grande di

quello che ti ho chiesto di cercare.

Quando lo trovi copiami il valore della cella adiacente .
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] Cerca ed estrai

Postdi Zetsu » 06/12/14 15:37

se uso la matrice F6/I125 , in E6 ho il valore prima , tipo


E F G H I
-575 -550 1,1 15 89

La cosa buffa è che funziona per la prima voce da estrarre, quindi come l' ho scritta, mentre per la seconda e terza voce,

che sono le colonne H e I mi restituisce come valore 0 ovunque.
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] Cerca ed estrai

Postdi Anthony47 » 06/12/14 15:46

Ma la formula che restituisce valori sballati quale e'?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Cerca ed estrai

Postdi Zetsu » 06/12/14 16:35

quando cambio la formula da cosi
=CERCA.VERT(A9;$F$6:$I$125;2;VERO)


a cosi
=CERCA.VERT(A9;$F$6:$I$125;3;VERO) e cosi =CERCA.VERT(A9;$F$6:$I$125;4;VERO)

ho risolto copiando le altre 2 colonne in altri 2 fogli, e usando la formula che funziona a 2 colonne

=CERCA.VERT(A9;$F$6:$I$125;2;VERO)

forse è un limite del cerca.verticale :)
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] Cerca ed estrai

Postdi ricky53 » 06/12/14 17:55

Ciao,
Uhm, Uhm, poco chiaro e NON convincente quanto hai scritto.

Per capire e, quindi, poterti aiutare ci occorre un file di esempio con dati effettivi contenente la formula che hai utilizzato tu.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Cerca ed estrai

Postdi Anthony47 » 06/12/14 22:53

forse è un limite del cerca.verticale
Finora cerca.vert non ha mai fatto sviste così clamorose... Attendiamo file di esempio.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Cerca ed estrai

Postdi Zetsu » 09/12/14 16:34

ecco il file, che adesso va proprio a banane perché mi sbaglia proprio riga....

http://www.filedropper.com/testcercavert

a voi la sentenza...

poco mi interessa dove posizionare i valori di ricerca, tanto devo metterli su un' altra pagina poi....

ma a me succede questo.

Ho evidenziato le righe.

Grazie a chiunque deciderà di controllare! :)
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] Cerca ed estrai

Postdi Anthony47 » 10/12/14 00:41

Per ottenere quello che vuoi il "cerca.vert" lo devi fare a partire dalla colonna B; ad esempio, per il dato di J9
Codice: Seleziona tutto
=CERCA.VERT($H9;test.cerca.vert!$B$8:$F$28;3;VERO)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Cerca ed estrai

Postdi Zetsu » 10/12/14 18:19

Perfetto!
Grazie mille!
In effetti non avevo proprio pensato a farlo partire dalla colonna prima.
credevo che per l' approssimazione servisse il numero più grande.
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Cerca ed estrai":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti