Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel 2010] macro con change data una certa condizione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: [excel 2010] macro con change data una certa condizione

Postdi ricky53 » 24/10/14 23:56

Ciao,
occorre avere tutte le informazioni per poterti aiutare.
Devi descrivere bene cosa hai come dati e cosa devi produrre.

Si può avere un file di esempio ma senza dati riservati,
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Sponsor
 

Re: [excel 2010] macro con change data una certa condizione

Postdi Zer0Kelvin » 26/10/14 15:34

Se, come sembra, avrai a che fare parecchio col VBA, il mio consiglio è questo.
Per imparare le basi, pima studiati qualcosa di elementare sulla programmazione in genere. Penso che in rete non dovrebbe essere difficile trovare qualcosa di adatto a te.
Per esempio, cercando un pò in rete ho trovato questo, che non sembra male
guida-vba
Dopo, cosa importantissima, cerca di capire cosa sono gli oggetti e come usarli ed impara a conoscere gli oggetti di Excel.
Excel, dal 2007 in poi, ha un ottimo help in linea (tasto F1), che è una vera miniera di informazioni. Si possono capire/imparare tantissime cose solo consultando l'help.
Tieni presente che l'help di VBA e quello di Excel sono due cose distinte.
[Win7,Office2010]
Condividere la conoscenza aumenta la ricchezza di tutti(Z0°K)
Dai ad un uomo un pesce e lo avrai sfamato per un giorno;insegnagli a pescare e lo avrai sfamato per sempre(Confucio)
Il sonno della ragione genera mostri(Francisco Goya)
Avatar utente
Zer0Kelvin
Utente Senior
 
Post: 305
Iscritto il: 08/04/12 11:23

Re: [excel 2010] macro con change data una certa condizione

Postdi ire.zazi » 27/10/14 09:02

Ok! Grazie per il consiglio. Infatti ho anche preso in prestito un manuale!
Mi accorgo di fare domande stupide, ma davvero non so dove sbattere la testa.
Io ho preparato un file senza dati personali, ma non so come fare per postarlo, nel senso che sia per l'immagine che per il file mi chiede il collegamento internet! http! Esiste un modo per postare una foto? oppure se qualcuno di voi mi manda la mia propria mail, vi giro la foto della mia tabella perchè davvero non so come fare.
Grazie mille ancora! =)
ire.zazi
Utente Junior
 
Post: 12
Iscritto il: 17/10/14 09:51

Re: [excel 2010] macro con change data una certa condizione

Postdi ire.zazi » 27/10/14 11:21

Immagine

Immagine Ho provato a caricare delle immagini.
ire.zazi
Utente Junior
 
Post: 12
Iscritto il: 17/10/14 09:51

Re: [excel 2010] macro con change data una certa condizione

Postdi ire.zazi » 28/10/14 09:45

Ragazzi!
Ho trovato il modo per allegare il mio file esempio!
Vi chiedo un altro aiuto.
http://www.filedropper.com/esempiofoglio

Provo a rispiegare la macro che mi servirebbe.

"partendo dalla cella attiva della colonna R (nel mio caso R4), mi sposto nella colonna N della stessa riga ( potrei usare Range("N" & I)), dove inserisco la data odierna.
Mi sposto poi nella colonna O inserendo la formula "=SE($H4="distensione";$P4-$B$2;SE($H4="Taglio a 1/2";$P4-$C$2;SE($H4="distensione+Taglio";$P4-$D$2;$P4+0)))";
Nella COLONNA P con la formula "=SE($U4="MORANDINI";SE(O(GIORNO.SETTIMANA($Q4)=6;GIORNO.SETTIMANA($Q4)=2);$Q4-4;SE(GIORNO.SETTIMANA($Q4)=3;$Q4-1;SE(O(GIORNO.SETTIMANA($Q4)=4;GIORNO.SETTIMANA($Q4)=7);$Q4-2;SE(O(GIORNO.SETTIMANA($Q4)=5;GIORNO.SETTIMANA($Q4)=1);$Q4-3;SE(GIORNO.SETTIMANA($Q4)=7;$Q4-1;SE(GIORNO.SETTIMANA($Q4)=1;$Q4-2))))));$Q4+0)";
nella COLONNA Q con la formula : "=$R4-CERCA.VERT($C4;$A:$AF;32;FALSO).
Alla fine della macro La mia cella attiva è nella colonna R nella riga successiva a quella precedente."
Vi ringrazio enormemente per la disponibilità e la pazienza dimostrata! =)
ire.zazi
Utente Junior
 
Post: 12
Iscritto il: 17/10/14 09:51

Re: [excel 2010] macro con change data una certa condizione

Postdi ire.zazi » 03/11/14 08:06

Non c'è più nessuno che mi può dare una mano?
ire.zazi
Utente Junior
 
Post: 12
Iscritto il: 17/10/14 09:51

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "[excel 2010] macro con change data una certa condizione":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti