Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula CERCA.VERT #N/D

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula CERCA.VERT #N/D

Postdi andrea.kimi » 29/09/14 09:18

Ciao a tutti,
Ho cercato nel forum un problema simile al mio ma non sono riuscito a trovare nulla che mi aiutasse a risolvere.
Vi spiego il mio problema: se la formula cerca.vert fa riferimento ad una cella contente una formula, ottengo #N/D.

Esempio pratico del mio caso:
- nella cella N9 ho un numero (dato dalla formula: =SE(O($AK9=140;$AK9=142);STRINGA.ESTRAI($B$9;18;5)&CONCATENA($AK9);STRINGA.ESTRAI($B$9;1;5)&CONCATENA($AK9)));
- nella cella AG9 inserisco la formula: =CERCA.VERT($N9;'Estrazione AX'!$A:$G;5;FALSO)

E' come se il cerca.vert cercasse non il numero risultante dalla formula ma cercasse la formula stessa. Perchè se il valore lo scrivo a "mano" il cerca.vert funziona. Premetto che nella cella B9 (da dove estraggo parte del numero) ho numeri ma anche del testo. Ho inoltre anche provato a formattare tutte le celle interessate come numero, ma nulla.

Qualche buon anima sa darmi qualche dritta? Io dopo tre giorni mi arrendo. :cry:
Vi ringrazio.
Andrea
andrea.kimi
Utente Junior
 
Post: 22
Iscritto il: 25/01/11 11:27

Sponsor
 

Re: Formula CERCA.VERT #N/D

Postdi Flash30005 » 29/09/14 10:27

Perché il "numero" che ottieni con la formula Concatena &... non è un numero ma un testo

Prova a mettere la funzione Valore(...) che racchiude il risultato dei singoli valori della tua formula
in questa maniera

Codice: Seleziona tutto
=SE(O($AK9=140;$AK9=142);Valore(STRINGA.ESTRAI($B$9;18;5)&CONCATENA($AK9));Valore(STRINGA.ESTRAI($B$9;1;5)&CONCATENA($AK9))));


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formula CERCA.VERT #N/D

Postdi andrea.kimi » 29/09/14 10:38

SEI UN GRANDE :) :) :) :) :)
Grazie davvero!
andrea.kimi
Utente Junior
 
Post: 22
Iscritto il: 25/01/11 11:27

Re: Formula CERCA.VERT #N/D

Postdi ninai » 29/09/14 11:50

ciao
oppure

=CERCA.VERT($N9+0;'Estrazione AX'!$A:$G;5;FALSO)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Formula CERCA.VERT #N/D

Postdi andrea.kimi » 29/09/14 12:19

Grazie mille anke a te ninai!!! Funziona anke il tuo metodo! ;)
andrea.kimi
Utente Junior
 
Post: 22
Iscritto il: 25/01/11 11:27

Re: Formula CERCA.VERT #N/D

Postdi andrea.kimi » 30/09/14 19:02

Scusate l'ignoranza ma cosa significa l'aggiunta di "+0" alla formula? In che modo cioè inganniamo la formula?
Sapete consigliare qualche "corso" di Excel, fatto bene, su internet?
Grazie
andrea.kimi
Utente Junior
 
Post: 22
Iscritto il: 25/01/11 11:27

Re: Formula CERCA.VERT #N/D

Postdi ninai » 01/10/14 06:29

ciao
tecnicamente non te lo so spiegare, ma usare +0, *1, ^1,--, sono dei modi che, quasi sempre, fanno capire ad excel che si tratta di numero e non di testo o di vero/falso. In questo modo si possono usare come numeri (fare calcoli).
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "Formula CERCA.VERT #N/D":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti