Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Messaggi a girare ogni 10 secondi con funzione orario

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Messaggi a girare ogni 10 secondi con funzione orario

Postdi Sasyjoe » 15/09/14 11:49

Ciao ragazzi,
tramite questa funzione vorrei mettere a girare 5 messaggi per un'ora (dalle 15 alle 16) ed ogni messaggio cambia ogni 10 secondi.

Spero che si può fare.

=SE(E(RESTO(ADESSO();1)>=ORARIO(15;0;0);RESTO(ADESSO();1)<ORARIO(15;0;10));A2;"Vietato")
=SE(E(RESTO(ADESSO();1)>=ORARIO(15;0;10);RESTO(ADESSO();1)<ORARIO(15;0;20));A2;"Vietato")
etc....

Spero ci sia un modo più rapido.

Vabene anche un'altra funzione chiaramente. Non vabene il vba.

vi ringrazio.

ciao
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Sponsor
 

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi Sasyjoe » 17/09/14 08:15

Ragazzi non esiste allora quello che chiedo? Grazie
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi ricky53 » 17/09/14 11:50

Ciao,
senza il VBA non si può fare ... tu hai scritto
Non vabene il vba.

ma penso che tu debba accettare una eventuale proposta in VBA
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi Sasyjoe » 17/09/14 16:36

Speravo in qualche vostra genialata! (Ricky, flash, anthony)
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi ricky53 » 17/09/14 16:53

Ciao,
Attendiamo ... MAI dire MAI !!!


Però con il VBA non è complesso da fare ... vedi tu. Se vuoi ne parliamo
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi Flash30005 » 18/09/14 01:15

Il fatto non è cercare una genialata
le formule una volte inserite rimangono lì e attendono anche 100 anni e oltre o almeno fino a che non si verifichi un cambiamento di cella che è contemplata nella formula stessa

Il consiglio di Richy era appunto l'utilizzo del VBA che ti permette almeno di ri-calcolare il foglio di Excel in n secondi/minuti/ore

Non capisco però come mai questa ritrosia all'uso del Vba che, se ben strutturato, non sai nemmeno che esiste e che lo stai utilizzando :)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi ricky53 » 18/09/14 08:50

Ciao,
come spunto, ad avvalorare quanto scritto da Flash pensa, ad un cronometro o al conto alla rovescia ... se cerchi nel forum o in rete troverai molti esempi che ti potranno convincere ... anche se non hai dimestichezza con il VBA
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi Sasyjoe » 18/09/14 16:40

Il Vba sicuramente ha potenzialità maggiori alle funzioni ma non lo so usare. Questo vorrebbe dire essere sul forum per ogni piccola modifica almeno per un paio di mesi!!

Grazie comunque. Se cambio idea chiaramente sarete i primi a saperlo!!
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: Messaggi a girare ogni 10 secondi con funzione orario

Postdi Flash30005 » 19/09/14 02:25

Non è così
se ti occorre un timer che faccia ricalcolare delle formule (tipo quella che hai pubblicato e che non ho valutato se efficace)
è sufficiente inserire quelle 3 righe di codice, solo una volta e non ci devi pensare più.

Comunque con le sole formule non risolverai il tuo problema.

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "Messaggi a girare ogni 10 secondi con funzione orario":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti