Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

confronto intervallo su diversi file excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

confronto intervallo su diversi file excel

Postdi lafefe » 15/07/14 15:15

Ciao a tutti,
vi chiedo un aiuto...
ho due file Excel che nella colonna A riportano dei codici mentre nella colonna K riportano delle quantità.
Dovrei verificare che il codice 90000011 abbia quantità = 2,00 sia nel file 1 che nel file 2, che il codice 90000012 abbia quantità = 2 sia nel file 1 che nel file 2 e così via.
esempio file 1
colonna A colonna K
90000011 2,00
90000012 2,00
90000015 2,00
90000016 18,00
90000021 1,00
90000022 1,00

esempio file 2
colonna A colonna K
90000011 3,00
90000020 2,00
90000015 2,00
90000016 8,00
90000021 1,00
90000026 4,00

ho evidenziato in blu le differenze tra la colonna A del file 1 e la colonna A del file 2 e tra la colonna K del file 1 e la colonna K del file 2.
poi, se possibile, che mi appaia una lista dei codici della colonna A presente nel file 1 ma non nel file 2 e una lista dei codici della colonna A presenti nel file 2 ma non nel file 1.
chiedo troppo ??! :undecided:
grazie!
lafefe
Newbie
 
Post: 2
Iscritto il: 15/07/14 14:50

Sponsor
 

Re: confronto intervallo su diversi file excel

Postdi Anthony47 » 16/07/14 00:20

Ciao lafefe, benvenuto nel forum.
Forse hai semplificato la descrizione del problema, che quindi e' piu' complesso di come l' ho capita; io infatti applicherei il filtro alla colonna K (quella delle quantita') e filtrerei per "diverso da 2": l' elenco che rimane e' quello dei codici che hanno qt diversa da 2.
Quanto alla "lista dei codici della colonna A presente nel file 1 ma non nel file 2 e una lista dei codici della colonna A presenti nel file 2 ma non nel file 1" lo puoi ottenere con Cerca.Vert, con in File1 una formula del tipo
Codice: Seleziona tutto
=CERCA.VERT(A2;[File2.xls]Foglio1!$A:$A;1;0)
e in File2
Codice: Seleziona tutto
=CERCA.VERT(A2;[File1.xls]Foglio1!$A:$A;1;0)

Dopo aver inserito la formula sulla riga 2 la copi verso il basso; i risultati #N/D indicano quei codici che mancano nell' altro file: ti bastera' filtrare la colonna dei risultati per avere tutto l' elenco dei codici mancanti nell' altro file, che puoi copiare in blocco e incollare su altro foglio, se necessario.

Lo stesso Cerca.Vert puo' aiutare a risolvere il primo quesito nell' ipotesi che non devi evidenziare le Qt diverse da 2 ma genericamente le quantita' diverse tra file1 e file2; per questo userai in File1 una formula del tipo:
Codice: Seleziona tutto
=CERCA.VERT(A2;[File2.xls]Foglio1!$A:$K;11;0)=K2

La inserisci su riga2 e poi la copi verso il basso. La formula restituira' #N/D per i codici mancanti in File1 e Falso per i codici dove le Qt sono diverse tra di loro.
Poi usi il filtro per filtrare i codici che ti interessano.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: confronto intervallo su diversi file excel

Postdi lafefe » 16/07/14 11:47

Ciao Anthony47,
ti ringrazio per la risposta, nel pomeriggio provo e ti faccio sapere!
ciao!
lafefe
Newbie
 
Post: 2
Iscritto il: 15/07/14 14:50


Torna a Applicazioni Office Windows


Topic correlati a "confronto intervallo su diversi file excel":


Chi c’è in linea

Visitano il forum: fabrizio2001 e 16 ospiti