Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Conta dei giorni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Conta dei giorni

Postdi charlie__00 » 14/07/14 12:43

Salve, ho bisogno di sapere come faccio in una cella ad avere come risultato il conto effettivo dei giorni, ad esempio:
CELLA A1: 01/07/2014
CELLA A2: 01/07/2014
CELLA A3: 02/07/2014

ADESSO A ME SERVE CHE LA CELLA "A4" RESTITUISCA LA SOMMA DEI GIORNI PRESI UNA SOLA VOLTA( ANCHE SE QUESTI SI RIPETONO) E QUINDI CHE MI DIA COME RISULTATO "2", ANCHE SE LA DATA 01/07/2014 è PRESENTE IN PIù CELLE.

N.B. OVVIAMENTE QUESTO è UN ESEMPIO, IO NE HO BISOGNO PERCHè LE DATE SI RIPETONO MOLTE VOLTE.

SPERO VIVAMENTE DI ESSERE STATO CHIARO.
charlie__00
Newbie
 
Post: 5
Iscritto il: 27/05/14 09:23

Sponsor
 

Re: Conta dei giorni

Postdi CANAPONE » 14/07/14 13:12

Ciao,

se le date sono in A2:A10 ed in A2:A10 non contiene celle vuote


Codice: Seleziona tutto
=SOMMA(1/CONTA.SE(A2:A10;A2:A10))


confermata con control+maiusc+invio fa il conteggio che chiedi.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Conta dei giorni

Postdi wallace&gromit » 14/07/14 13:51

se ho capito bene questa formula dovrebbe andare bene (adatta tu al numero di righe richiesto):
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(SE(VAL.NUMERO(CONFRONTA(RIF.RIGA($A$2:$A$10)-1;CONFRONTA($A$2:$A$10;$A$2:$A$10;0);0));1;0))
è una formula matriciale che devi confermare con ctrl+maiusc+enter e non solo enter.

Nota:Le date devono riferirsi a giorni interi, se invece nel tuo database sono definiti anche gli orari, ogni singolo orario sarà trattato in modo individuale.

Edit: Canapone mi ha battuto in velocità e qualità! e non riesco a cancellare il mio post, non mi resta che subire l'onta :oops: :lol:
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Conta dei giorni

Postdi charlie__00 » 21/07/14 15:31

GRAZIE MILLE!! a tutti quelli che mi hanno risposto.
Ma in particolare a "canapone", rapido ed efficace.

N.B. avete migliorato la qualità della vita lavorativa.
charlie__00
Newbie
 
Post: 5
Iscritto il: 27/05/14 09:23

Re: Conta dei giorni

Postdi ninai » 22/07/14 06:22

wallace&gromit ha scritto:Edit: Canapone mi ha battuto in velocità e qualità! e non riesco a cancellare il mio post, non mi resta che subire l'onta :oops: :lol:


Wallace
A parte l' indubbia efficacia ed appropriatezza della formula di Canapone (non poteva essere diversamente), ho apprezzato pure la tua proposta, ben si adatta anche a dati di testo, mi sono permesso una sfoltita:
=SOMMA(--VAL.NUMERO(CONFRONTA(RIF.RIGA($A$2:$A$10)-1;CONFRONTA($A$2:$A$10;$A$2:$A$10;0);0)))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Conta dei giorni

Postdi wallace&gromit » 22/07/14 08:36

apprezzo le parole di conforto :D
ho provato anche io con la tecnica del "--" invece di "SE", però non la padroneggio ancora e mi era uscita una ciofeca, col tempo ci arriverò.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Conta dei giorni":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti