Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]Media ponderata escludendo celle vuote

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]Media ponderata escludendo celle vuote

Postdi mattiaprodomo » 20/06/14 10:44

buongiorno a tutti,
stavo facendo un foglio di lavoro con excel per calcolare la media ponderata dei miei esami universitari. Fin qui tutto bene il problema è che visto che non ho fatto tutti gli esami mi comprende anche le celle vuote quindi la media è sbagliata.
La formula della media è MATR.SOMMA.PRODOTTO(B3:B30;C3:C30)/SOMMA(B3:B30). Ho bisogno che quei B30 e quel C30 si aggiornino solo alle celle piene....quindi per esempio B17 e C17......automaticamente.

Grazie mille
mattiaprodomo
Newbie
 
Post: 1
Iscritto il: 20/06/14 09:58

Sponsor
 

Re: [Excel]Media ponderata escludendo celle vuote

Postdi ricky53 » 22/06/14 19:23

Ciao,
non hai detto cosa contengono le celle dell'intervallo "B3:B30" e quelle di "C3:C30"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel]Media ponderata escludendo celle vuote

Postdi ninai » 22/06/14 19:37

ciao
oltre a rimarcare il quesito di Ricky (un saluto), credo che non dovrebbero incidere le celle vuote, se poi in B non sono vuote, usa Somma.se()
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: [Excel]Media ponderata escludendo celle vuote

Postdi ricky53 » 22/06/14 22:07

Ciao,
se i dati in "B3:C30"" sono allineati (ossia non esistono celle in colonna "B" contenenti valori la cui stessa riga in colonna "C" sia SENZA valori) la tua formula fornisce valori esatti.

Se fai un esempio con i dati che effettivamente hai nella tue celle ti potremo aiutare in modo fattivo senza fare ipotesi.



P.S.: Ricambio il saluto a Ninai
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel]Media ponderata escludendo celle vuote

Postdi wallace&gromit » 23/06/14 17:41

non hai risposto alle domande che ti sono state poste, comunque provo ad azzardare una formula:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B4:B31;C4:C31)/MATR.SOMMA.PRODOTTO(SE(C4:C31<>"";1;0);B4:B31)
da confermare premendo Ctrl + Maiusc + Enter e non il solo Enter (è una formula matriciale).
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: [Excel]Media ponderata escludendo celle vuote

Postdi ninai » 23/06/14 18:23

wallace&gromit ha scritto:non hai risposto alle domande che ti sono state poste, comunque provo ad azzardare una formula:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B4:B31;C4:C31)/MATR.SOMMA.PRODOTTO(SE(C4:C31<>"";1;0);B4:B31)
da confermare premendo Ctrl + Maiusc + Enter e non il solo Enter (è una formula matriciale).


Ciao
E' più o meno quello che avevo proposto prima, ma il SE() ed il matriciale dovrebbero essere superflui:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B4:B31;C4:C31)/MATR.SOMMA.PRODOTTO((C4:C31<>"")*B4:B31)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]Media ponderata escludendo celle vuote":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti

cron