Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Creare una classifica avendo già il calendario

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: [Excel] Creare una classifica avendo già il calendario

Postdi robygragio » 26/06/14 15:47

allora per quando riguarda gli errori che ti mette tutte le squadre,
per la semifinale
metti in Y87 la formula =SE(O(Q81="";Q82="");"";SE(Q81>Q82;O81;O82))
metti in Y88 la formula =SE(O(Q93="";Q94="");"";SE(Q93>Q94;O93;O94))
metti in Y111 la formula =SE(O(Q105="";Q106="");"";SE(Q105>Q106;O105;O106))
metti in Y112 la formula =SE(O(Q117="";Q118="");"";SE(Q117>Q118;O117;O118))

per la finale
metti in AF99 la formula =SE(O(AA87="";AA88="");"";SE(AA87>AA88;Y87;Y88))
metti in AF100 la formula =SE(O(AA111="";AA112="");"";SE(AA111>AA112;Y111;Y112))

per la finale 3/4 Posto
metti in Y99 la formula =SE(O(AA87="";AA88="");"";SE(AA87<AA88;Y87;Y88))
metti in Y100 la formula =SE(O(AA111="";AA112="");"";SE(AA111<AA112;Y111;Y112))

Prova e fammi sapere se e giusto piu tardi provo il metodo di Anthony se funziona :P
Win7 + Office 2007 Ita
robygragio
Utente Junior
 
Post: 29
Iscritto il: 09/12/12 12:58

Sponsor
 

Re: [Excel] Creare una classifica avendo già il calendario

Postdi robygragio » 26/06/14 21:38

Scusami anthony ma ho avuto solo adesso il tempo di provare, allora il tuo codice funziona, ci sono pero 2 cose che non vanno, praticamente non mi fa mettere il risultato completo che all'improviso mi porta alla cella dove copia l'immagine, faccio un esempio se io voglio mettere il risultato del gruppo b, Australia- Spagna 0-3, appena inserisco lo Zero la pagina si sposta nella cella dove copia l'immagine, e questo lo fa anche se metto altri risultati.
Secondo problema non mi centra l'icona nella cella se mi daresti un occhiata al file forse ho sbagliato io qualcosa, intanto ti rigrazio per l'aiuto dato in precedenza.

File: Mondiale 2014 con Modifiche Anthony
Win7 + Office 2007 Ita
robygragio
Utente Junior
 
Post: 29
Iscritto il: 09/12/12 12:58

Re: [Excel] Creare una classifica avendo già il calendario

Postdi Anthony47 » 27/06/14 01:47

Nella Private Sub Workbook_SheetChange, subito prima di " Err1:" inserisci
Codice: Seleziona tutto
ActiveWindow.RangeSelection.Select

Per il secondo problema, modifica la parte centrale della Sub copImm in:
Codice: Seleziona tutto
   For Each Sh In ActiveSheet.Shapes
'   aaa = Sh.TopLeftCell.Address(0, 0)
        If Sh.TopLeftCell.Address(0, 0) = Sorg Then
            Sh.Copy
'            Range(Dest).Select
            ActiveSheet.Paste
            Selection.Name = "ZC_" & Dest
            ActiveSheet.Shapes("ZC_" & Dest).Left = Range(Dest).Left + (Range(Dest).Width - ActiveSheet.Shapes("ZC_" & Dest).Width) / 2
            ActiveSheet.Shapes("ZC_" & Dest).Top = Range(Dest).Top + (Range(Dest).Height - ActiveSheet.Shapes("ZC_" & Dest).Height) / 2
'            Range(Dest).Select
            Exit For
       End If
    Next Sh

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Creare una classifica avendo già il calendario

Postdi dmitrij7 » 27/06/14 08:33

robygragio ha scritto:allora per quando riguarda gli errori che ti mette tutte le squadre,
per la semifinale
metti in Y87 la formula =SE(O[b](Q81="";Q82="");"";SE(Q81>Q82;O81;O82))[/b]
metti in Y88 la formula =SE(O[b](Q93="";Q94="");"";SE(Q93>Q94;O93;O94))[/b]
metti in Y111 la formula =SE(O[b](Q105="";Q106="");"";SE(Q105>Q106;O105;O106))[/b]
metti in Y112 la formula =SE(O[b](Q117="";Q118="");"";SE(Q117>Q118;O117;O118))[/b]

per la finale
metti in AF99 la formula =SE(O[b](AA87="";AA88="");"";SE(AA87>AA88;Y87;Y88))[/b]
metti in AF100 la formula =SE(O[b](AA111="";AA112="");"";SE(AA111>AA112;Y111;Y112))[/b]

per la finale 3/4 Posto
metti in Y99 la formula =SE(O[b](AA87="";AA88="");"";SE(AA87<AA88;Y87;Y88))[/b]
metti in Y100 la formula =SE(O[b](AA111="";AA112="");"";SE(AA111<AA112;Y111;Y112))[/b]

Prova e fammi sapere se e giusto piu tardi provo il metodo di Anthony se funziona :P


Si funziona :) Il problema era nelle parti che ti ho segnato in grassetto: al posto di Q c'era O e al posto di AA c'era Y :lol:
dmitrij7
Newbie
 
Post: 7
Iscritto il: 13/06/14 21:50

Re: [Excel] Creare una classifica avendo già il calendario

Postdi robygragio » 29/06/14 21:18

grazie ancora anthony adesso va tutto a meraviglia, unico neo negativo e nell'inserire i risultati ci mette un po per copiare e incollare il tutto man mano che finiscono i gironi, ci voleva un modo piu veloce per fare il tutto, comunque il codice funziona tutto alla perfezione se ce qualcuno che vuol dare suggerimenti per migliorarlo ben venga.

eccovi il file modificato:
Mondiale 2014
Win7 + Office 2007 Ita
robygragio
Utente Junior
 
Post: 29
Iscritto il: 09/12/12 12:58

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Creare una classifica avendo già il calendario":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti