Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma giorni dello stesso mese

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma giorni dello stesso mese

Postdi Cedamido » 18/05/14 19:52

Ho un elenco di date un po lungo che riguardano tutti i mesi dell'anno:
cella F4 c'è la prima data iniziale per esempio 01/09/2014 cella G4 la prima data finale 09/09/2014 gg 8, i giorni sono nella colonna H e sono stati ricavati con il metodo festivo appreso su questo Forum da istruzioni Antony e Rick, le date con i giorni sono stati riportati in altro foglio, le date non sono in ordine crescente per mese sono mischiate, essendo mischiate dovrei ricavare il totale numero dei giorni per mese in una sola cella, per esempio tutti i giorni che appartengono a gennaio 2014 devono essere scritti in una cella e così via per gli altri giorni relativi agli altri mesi.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Somma giorni dello stesso mese

Postdi ricky53 » 19/05/14 00:16

Ciao,
potresti utilizzare una tabella pivot e come campi "righe" la colonna delle date e come campi dati sempre la stessa colonna.
Poi con raggruppa selezionando "Mese" avresti quante volte è presente la data nei vari mesi

Prova e sono QUI !!!

Se il problema dovesse essere più complesso di come lo hai esposto allora occorre un file di esempio
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Somma giorni dello stesso mese

Postdi Cedamido » 19/05/14 21:25

Ultima modifica di Cedamido su 19/05/14 21:29, modificato 2 volte in totale.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma giorni dello stesso mese

Postdi Cedamido » 19/05/14 21:26

excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma giorni dello stesso mese

Postdi Cedamido » 19/05/14 21:28

Ho provato ad allegare il file, non so se ci sono riuscito.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma giorni dello stesso mese

Postdi ricky53 » 19/05/14 22:15

Ciao,
non mi è molto chiaro cosa vuoi fare e per questo ti chiedo: "data1" e "data2" sono sempre date dello stesso mese oppure "data2" può essere uno dei mesi successivi rispetto a "data1" ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Somma giorni dello stesso mese

Postdi Cedamido » 19/05/14 22:37

Non riesco mai a farmi capire perchè non riesco a scrivere ciò che desidero,la data1 e la data2 devono essere dello stesso mese e stesso anno, il file che ho allegato non quadra per due giorni, non riesco a mettere la formula esatta, mi sembra che i giorni mensili non coincidono con i giorni della colonna C forse perchè sono ricavati con il metodo festivo.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma giorni dello stesso mese

Postdi ricky53 » 19/05/14 23:04

Ciao,
si è proprio così: differenza di metodo per il calcolo dei giorni tra le due date.

Per me ti sei complicato la vita.
Domani vedo di darti delle indicazioni per semplificare la soluzione.

Nella formule di riga "35" parti dalla riga "4" invece che dalla "3"
Errata
Codice: Seleziona tutto
=SOMMA(D4:D34)



Esatta
Codice: Seleziona tutto
=SOMMA(D3:D34)


Stessa cosa per le altre formule nelle colonne "E-O" della riga "35"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Somma giorni dello stesso mese

Postdi ninai » 20/05/14 06:27

Ciao
la formula in C (bella!!, non la conoscevo), include nel conteggio, sia il giorno iniziale che quello finale.
Le formule in D:O, non tengono conto dei festivi e conteggiano solo giorno iniziale o finale
Se, come dici, le due date per riga, saranno sempre dello stesso mese e anno, forse potresti usare sempre la formula di C, condizionata al mese della colonna. esempio, in D3:
Codice: Seleziona tutto
=SE(E($A3<>""; $B3<>"";MESE($B3)=D$2); MATR.SOMMA.PRODOTTO((GIORNO.SETTIMANA(RIF.RIGA(INDIRETTO($A3&":"&$B3));3 )<6) * (CONTA.SE(festivi;RIF.RIGA(INDIRETTO($A3& ":" &$B3)))=0)); 0)

e trascini.
(per togliere un giorno (inizio o fine), basta aggiungere -1, prima dell'ultimo punto e virgola).
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Somma giorni dello stesso mese

Postdi Anthony47 » 20/05/14 11:08

Non l' hai detto, ma mi pare che stai calcolando i giorni lavorativi nei vari periodi compreso il sabato ed scludendo le festivita', per poi spalmarli nei 12 mesi.
La formula in colonna C fa egregiamente il lavoro (il problema era stato ampiamente discusso qui: viewtopic.php?f=26&t=87181).
Per la sistemazione nella giusta colonna andra' bene la formula di ninai (vedi sopra), con l' ovvia semplificazione
Codice: Seleziona tutto
=SE(E($A3<>""; $B3<>"";MESE($B3)=D$2); $C3;0)


Rimane da correggere anche quanto segnalato da Ricky per le formule in D35 (e adiacenti), che deve essere
Codice: Seleziona tutto
=SOMMA(D3:D34)

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma giorni dello stesso mese

Postdi ninai » 20/05/14 11:36

opps, vero!! la formula già era presente, che distratto!!
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Somma giorni dello stesso mese

Postdi Cedamido » 20/05/14 14:29

=SE(E($A3<>""; $B3<>"";MESE($B3)=D$2); $C3;0)
Questa va benissino solo che come al solito ho dimenticato di dire che le date provengono da altro foglio e riportate con =se(nomefoglio!b14="";"";nomefoglio!b14) quando sul foglio di provenienza non vi sono le date nelle celle della tabella mensile appaiono i cancelletti oppure la parola valore.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Somma giorni dello stesso mese

Postdi Anthony47 » 20/05/14 15:35

Prova a usare
Codice: Seleziona tutto
=SE(E($A3<>""; $B3<>"";MESE(0&$B3)=D$2); $C3;0)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Somma giorni dello stesso mese

Postdi Cedamido » 21/05/14 06:54

Funziona alla grande, grazie.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26


Torna a Applicazioni Office Windows


Topic correlati a "Somma giorni dello stesso mese":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti