Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula trova numeri uguali con valore più alto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula trova numeri uguali con valore più alto

Postdi Statix » 04/05/14 18:44

Ciao a tutti,
stò cercando di risolvere il problema con delle formule ma al momento non mi viene nulla,riesco a risolvere in parte.
ho 270 righe,
in ogni riga di 90 celle ho 90 valori diversi
in questa riga devo trovare 2 o più numeri uguali ma con i valori piu alti
esempio riga Q4:DB4 1-3-56-34-23-57-89-90-123-27-46-75-78-56-89-75-33-54-75 etc.etc
numeri uguali 56
numeri uguali 75 quindi il valore trovato è 75 i numeri uguali sono 3 in cella DF4 =3 e in cella DG4 il valore 75
se non ci sono numeri uguali = 0
questo per 270 righe, servirebbe una formula o al massimo una macro
Range da AQ4:DB273 quanti numeri trovati in colonna DF4:DF273 il valore del numero in DG4:DG273
grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Formula trova numeri uguali con valore più alto

Postdi ninai » 04/05/14 19:38

Ciao
se ho ben capito:
in Df4: =SOMMA(--(FREQUENZA(Q4:DB4;Q4:DB4)>1))
dai numeri di esempio, quelli ripetuti mi risultano due, 56 e 75.

in DG4: =MAX(INDICE((CONTA.SE($Q4:$DB4;$Q4:$DB4)>1)*$Q4:$DB4;;))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Formula trova numeri uguali con valore più alto

Postdi scossa » 04/05/14 19:46

In DG4:
Codice: Seleziona tutto
=MAX(INDICE((CONTA.SE($Q4:$DB4;$Q4:$DB4)>1)*$Q4:$DB4;))


in DF4:
Codice: Seleziona tutto
=CONTA.SE($Q4:$DB4;$DG4)
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: Formula trova numeri uguali con valore più alto

Postdi Statix » 04/05/14 19:54

Ciao Scossa,
tutto ok, grazie
grazie anche a ninai
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "Formula trova numeri uguali con valore più alto":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti