Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula complessa Excel in convalida dati ad elenco

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula complessa Excel in convalida dati ad elenco

Postdi jtz81 » 30/04/14 11:23

Ciao a tutti.
Ho un problema con una formula excel, scusate ma non sono un professionista, lo uso a volte per lavoro. Avrei bisogno di scrivere una formula di questo tipo, nella convalida dati ad elenco:
Se una cella (a1) è uguale ad una delle celle (f2,f3,f4,f5) allora voglio come risultato c5, se invece è uguale a (f6,f7,f8) allora come risultato c6, se invece è uguale a (f9,f10,f11....f99) allora voglio come risultato le celle c7,c8, c9.

è possibile scrivere una formula del genere nelle convalide dati? Come?
Vi ringrazio infinitamente.
jtz81
Newbie
 
Post: 1
Iscritto il: 30/04/14 11:11

Sponsor
 

Re: Formula complessa Excel in convalida dati ad elenco

Postdi ricky53 » 30/04/14 12:20

Ciao,
prima di tutto BENVENUTO nel nostro forum.


Le condizioni sono solo quelle esposte o ne hai altre che non sono state riportate?
Non capisco come tu abbia pensato di collegare una formula che scrive dei dati in una cella alla convalida!


Comunque sarebbe preferibile che tu descrivessi cosa effettivamente ti occorre e non limitare la richiesta a come impostare una formula.

La soluzione è sicuramente condizionata dalla necessità effettiva e dalla struttura dei dati.
Dovresti anche descrivere come sono organizzati i tuoi dati.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula complessa Excel in convalida dati ad elenco

Postdi Anthony47 » 30/04/14 12:33

Ciao jtz81, benvenuto nel forum.
In una cella libera del tuo foglio (io ho usati I1), inserisci questa formula:
Codice: Seleziona tutto
=SE(CONFRONTA(A1;F2:F20;0)<5;0;SE(CONFRONTA(A1;F2:F20;0)<8;1;SE(CONFRONTA(A1;F2:F20;0)<100;2;0)))


In tre colonne libere adiacenti, replica il contenuto delle celle che vuoi usare come convalida. Io ho usato le colonna L:N, e in L1 ho usato la formula
Codice: Seleziona tutto
=SE(C5<>"";C5;"")
Le altre celle avranno formule simili.
Poi assegna il nome DINA1 a un intervallo dinamico; la procedua per assegnare un "nome" varia secondo le versioni di Excel, in XL2003:
-Menu /Inserisci /Nome /Definisci
-Come "Riferito a" userai la formula
Codice: Seleziona tutto
=SCARTO(Foglio2!$L$1;0;Foglio2!$I$1;4;1)

-Completi la procedura con gli Ok o i Chiudi giusti

Se la prima formula non e' messa in I1, o se l' elenco non e' stato creato in L1 e diacenti, modifica la formula rispettando assolutamente la sintassi data (compreso il nome foglio e i $)

Poi nella cella in cui vuoi inserire la convalida indicherai una convalida da Elenco e come origine indicherai =DINA1

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Formula complessa Excel in convalida dati ad elenco":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti