Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula Ordinamento dati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula Ordinamento dati

Postdi Statix » 26/03/14 11:39

Ciao a tutti,
ho un problema a trovare una formula giusta per ordinare i dati come foto allegata,
quindi mi servirebbe un aiuto per la formula o formule max 2 colonne appoggio,
no macro in quanto gli ordinamenti sono molteplici ed in diversi range.
grazie in anticipo
PS dimenticavo nell'esempio della prima tabella nelle celle dei numeri (colonna D )ci sono formule cerca.vert.

Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Formula Ordinamento dati

Postdi ninai » 26/03/14 12:58

CIAO
se ho ben capito ed in base ai riferimenti dell' immagine:
in H4:
=SE.ERRORE(PICCOLO($D$4:$D$13;RIF.RIGA(A1));"")
in G4:
=SE.ERRORE(INDICE($C$4:$C$13;PICCOLO(SE($D$4:$D$140=H4;RIF.RIGA($C$4:$C$13)-3);CONTA.SE($H$4:H4;H4)));"")
Questa è matriciale , da confermare con CTRL+MAIUSC+INVIO
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Formula Ordinamento dati

Postdi Statix » 26/03/14 14:22

Ciao ninai,
la prima formula funziona bene,
la seconda non riesco ad adattarla agli altri range,non mi da nulla,
a parte la piccola correzione 140 con 14
se i range sono tutti attaccati
C:D e i dati in E:F
bisogna modificare quel -3 ?
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula Ordinamento dati

Postdi Statix » 26/03/14 14:32

ok, ho capito il problema quel -3 sono le righe vuote prima della tabella ,
ho risolto, grazie infinite
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "Formula Ordinamento dati":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti