Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca verticale di 3 valori contemporaneamente

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca verticale di 3 valori contemporaneamente

Postdi femon » 18/03/14 18:22

Salve a tutti,
avrei un quesito: è possibile con una macro o formula cercare i valori della colonna j, k e l in una altra tabella che ha queste informazioni nelle colonne a b e c e poi restituirmi come risultato il valore della colonna d di questa tabella?
es:
colonna a è il cognome
colonna b è il nome
colonna c è data di nascita
Quando ha trovato corrispondenza di tutte queste 3 colonne mi restituisce il valore presente nella colonna d della tabella dove ha cercato.
Lo scopo è quello di casi di omonimia dove solo dopo aver controllato anche la colonna della data di nascita ho l'unicità del record.
Con il cerca verticale mi cerca solo una colonna e non tutte e tre.
Grazie a chi può aiutarmi.
femon
Utente Junior
 
Post: 47
Iscritto il: 12/03/14 18:51

Sponsor
 

Re: cerca verticale di 3 valori contemporaneamente

Postdi alfrimpa » 18/03/14 19:26

Ciao

Io inserirei una colonna di appoggio (in colonnaA magari da nascondere) dove concatenerei cognome, nome e data di nascita (in modo da avere valori univoci) e farei la ricerca con il cerca.vert su quella.

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 842
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: cerca verticale di 3 valori contemporaneamente

Postdi ninai » 18/03/14 19:34

con una colonna di appoggio , la A nella quale concateni b c d basta un cerca.vert(F1&G1&H1;A1:E20;4;falso).

Diversamente, senza appoggio:
=INDICE($D$1:$D$20;CONFRONTA(F1&G1&H1;$A$1:$A$20&$B$1:$B$20&$C$1:$C$20;0))
in F1, G1, H1 i dati da cercare
Matriciale da confermare con CTRL+MAIUSC+INVIO
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: cerca verticale di 3 valori contemporaneamente

Postdi femon » 19/03/14 18:35

Ottimo, ho optato per la colonna di appoggio.
Funziona.
Grazie.
Saluti. :D :D :D
femon
Utente Junior
 
Post: 47
Iscritto il: 12/03/14 18:51


Torna a Applicazioni Office Windows


Topic correlati a "cerca verticale di 3 valori contemporaneamente":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti