Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel - somme con riferimento non fisso

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel - somme con riferimento non fisso

Postdi Sasyjoe » 24/02/14 17:51

Buonasera,
devo fare una somma con l'inizio dell'intervallo da sommare variabile.

Il valore variabile tramite alcune formule, so dove è posizionato con il rif riga (70) e rif colonna (5).

La matrice è E69:E100.

Vorrei che il primo valore lo stabilisco in base al rif riga e rif colonna e l'ultimo valore dell'intervallo sia e100.
(da esempio rif riga (70) e rif colonna (5) = E70, quindi somma(e70:e100))


Come faccio?
Grazie
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Sponsor
 

Re: excel - somme con riferimento non fisso

Postdi ninai » 24/02/14 18:30

ciao
=SOMMA(INDIRETTO(INDIRIZZO(70;5)&":E100"))

se serve, in indirizzo(), puoi parametrare il 70 ed il 5 con delle celle e/o formule
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: excel - somme con riferimento non fisso

Postdi Sasyjoe » 24/02/14 19:34

MITICO!!
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: excel - somme con riferimento non fisso

Postdi Sasyjoe » 05/03/14 16:43

Buonasera,
Ho un altro problema molto simile al precedente:

Sulla colonna D ho i giorni, sulla colonna F ho degli importi

Esempio

1/1/14 10
2/1/14 12
3/1/14 0
4/1/14 5

e così via.

Vorrei sapere quanti zeri ci sono dal primo del mese fino ad oggi.
Gli importi iniziano in F69, quindi come inizio intervallo scrivo F69. Il fine intervallo è F69 + giorno(oggi()).

La formula la ho scritta così, cosa sbaglio?


=CONTA.SE(INDIRETTO(F69&F69+GIORNO(OGGI()));"0")
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: excel - somme con riferimento non fisso

Postdi Sasyjoe » 05/03/14 16:55

Ho risolto così:

=CONTA.SE(INDIRETTO("f69:f"&68+GIORNO(OGGI()));"0")

Adesso mi servirebbe impostare la formula in modo tale che conta, a partire da oggi a salire, solo tutti gli zeri consecutivi.

Per farmi capire:


1/3/14 ----- 20
2/3/14 ----- 0
3/3/14 ----- 12
4/3/14 -----0
5/3/14 ----- 0

Giorni colonna D69:D100 - Importi colonna F69:F100

Come ho impostato adesso la formula, mi da risultato 3, perchè conta i 3 zeri.
Io vorrei come risultato 2, cioè solo i due zeri consecutivi a partire da oggi a salire.
Se oggi è 5/3/14 e sia oggi che ieri ho l'importo 0, ed il 3/2/14 ho un importo >0, vorrei come risultato 2 perchè ho due zeri consecutivi (il giorno 4 e 5/3/14).

Spero di essere stato chiaro.
Il conteggio parte sempre da oggi a salire.
Sasyjoe
Utente Senior
 
Post: 404
Iscritto il: 04/05/12 13:27

Re: excel - somme con riferimento non fisso

Postdi Anthony47 » 06/03/14 00:58

Una formula equivalente a quella che hai usato potrebbe essere
Codice: Seleziona tutto
=CONTA.SE(SCARTO($E$69;0;0;GIORNO(OGGI());1);0)


Per il nuovo problema, purtroppo il termine "da oggi a salire" e' equivoco: significa "da oggi in avanti" o "da oggi all' indietro"? Dall' esempio che hai fatto sembrerebbe che per te "salire" significhi "andare indietro".
In questo caso suggerirei:
Codice: Seleziona tutto
=SOMMA((SCARTO($E$69;0;0;GIORNO(OGGI());1)=0)*(SCARTO($E$69;-1;0;GIORNO(OGGI());1)=0)*(SCARTO($E$69;0;0;GIORNO(OGGI());1)<>""))
Le celle vuote sono ignorate; in E68 deve essere presente una intestazione testuale.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel - somme con riferimento non fisso":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti

cron