Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel funzione se nidificata con funzione confronta???

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel funzione se nidificata con funzione confronta???

Postdi trix » 16/02/14 15:25

Gentili Utenti,
ho bisogno di un aiuto per risolvere il mio problema.

Devo fare un computazione di errori in excel su una lunga lista di valori.
Nella colonna A ho due tipi di categorie (cucina o giardino) mentre nella colonna B ho i valori Sinistra o Destra.
Ho bisogno di impostare un'espressione in excel tale che:
-quando nella colonna A la cella "cucina" corrisponde nella colonna B alla cella "Sinistra" la mia espressione sarà vera altrimenti se "destra" falsa
-quando nella colonna A la cella giardino corrisponde alla cella "destra" nella colonna B la mia espressione sarà vera altrimenti falsa.

Spero di essere stata abbastanza chiara nella spiegazione.
Grazie per qualsiasi input!
trix
Newbie
 
Post: 1
Iscritto il: 16/02/14 15:17

Sponsor
 

Excel funzione se nidificata con funzione confronta?

Postdi CANAPONE » 16/02/14 15:43

Ciao

potrebbe servire per ottenere 1/0

Codice: Seleziona tutto
=(A2="Cucina")*(B2="Sinistra")+(A2="Giardino")*(B2="Destra")


che può essere scritta così

Codice: Seleziona tutto
=(A2&B2="Cucinasinistra")+(A2&B2="Giardinodestra")



oppure per ottenere VERO FALSO

Codice: Seleziona tutto
=SE((A2&B2="Cucinasinistra")+(A2&B2="Giardinodestra");VERO)


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: excel funzione se nidificata con funzione confronta???

Postdi Anthony47 » 17/02/14 00:54

Ciao trix, benvenuto/a nel forum.
Alle varie formule magiche di canapone aggiungo questa:
Codice: Seleziona tutto
=O(E(A2="Cucina";B2="Sinistra");E(A2="Giardino";B2="Destra"))

Restituita' VERO sulle due condizioni da te descritte, FALSO sulle altre.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel funzione se nidificata con funzione confronta???":


Chi c’è in linea

Visitano il forum: patel e 4 ospiti