Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel 2003: sommare se su due colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel 2003: sommare se su due colonne

Postdi karug64 » 12/02/14 13:10

Salve a tutti.
Ho un foglio con le colonne F e G in cui ho dei valori fissi ("Da provare", "Provata")
Mi occorrerebbe ottenere in cella F7 il numero di volte che è presente "Da provare" su entrambe le colonne.
Esempio.

Da provare Provata
Da provare Da provare
Provata Provata
Provata Da provare
Da provare Provata

In F7 dovrei avere =4 ossia quante volte "Da provare" sia presente almeno uan volta in ogni coppia di celle.

Sicuramente la soluzione prevede una formula matriciale, ma se fosse possibile per me sarebbe meglio averne una non matriciale in quanto, probabilmente, questa formula dovro' scriverla all'interno di un codice VBA per aasegnarla alla cella e non so come fare.

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel 2003: sommare se su due colonne

Postdi Anthony47 » 12/02/14 13:18

Codice: Seleziona tutto
=Conta.se(F:G;"Da provare")

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: sommare se su due colonne

Postdi scossa » 12/02/14 13:37

Anthony47 ha scritto:
Codice: Seleziona tutto
=Conta.se(F:G;"Da provare")

Ciao


Ciao,

così però conta TUTTE le ricorrenze di "Da provare" e, coi dati dell'esempio, riporterebbe 5 anziché 4.

Ipotizzando i dati dell'esempio in F9:G13, Io suggerisco:
Codice: Seleziona tutto
=SOMMA(INDICE(--NON(F9:F13&G9:G13="ProvataProvata");))
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: excel 2003: sommare se su due colonne

Postdi Anthony47 » 12/02/14 15:05

E' vero, non avevo letto "ossia quante volte "Da provare" sia presente almeno una volta in ogni coppia di celle".

Pero' non mi torna nemmeno la tua formula, scossa...

Al meglio della mia comprensiore attuale (delle 15:04) una formula potrebbe essere
Codice: Seleziona tutto
=CONTA.SE(F10:G100;"Da provare")-SOMMA(--(F10:F100&G10:G100="Da provareDa provare"))
Da confermare con Contr-Maiusc-Enter, non il solo enter.

Ciao a tutti!
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: sommare se su due colonne

Postdi scossa » 12/02/14 17:33

Anthony47 ha scritto:Pero' non mi torna nemmeno la tua formula, scossa...


In che senso non ti torna.
Io ho preso i dati dell'esempio e do per scontato che le celle contengano tutte uno dei due valori.
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: excel 2003: sommare se su due colonne

Postdi Anthony47 » 13/02/14 00:02

scossa ha scritto:
Anthony47 ha scritto: Pero' non mi torna nemmeno la tua formula, scossa...


In che senso non ti torna.
Io ho preso i dati dell'esempio e do per scontato che le celle contengano tutte uno dei due valori.

E alle 24:00 cosa vuoi che ne sappia di cosa non mi quadrava alle 15:05??? :D :D
(mah, diciamo che ho avuto una giornata dura... Probabilmente ho testato scrivendo in celle fuori dagli indirizzi che avevi messo e dichiarato nelle formule :oops: )

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: sommare se su due colonne

Postdi scossa » 13/02/14 09:12

Anthony47 ha scritto:E alle 24:00 cosa vuoi che ne sappia di cosa non mi quadrava alle 15:05??? :D :D


Eh, ti capisco, capita anche a me :)
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona


Torna a Applicazioni Office Windows


Topic correlati a "excel 2003: sommare se su due colonne":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti