Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel 2010: riferimenti a celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel 2010: riferimenti a celle

Postdi karug64 » 09/02/14 18:56

Salve a tutti.
Continuo il mio post precedente (come argomento) per domandarvi:

Ho allegato il file
http://www.filedropper.com/dieta-2014
in quanto la richiesta è difficile da formulare. Ci provo, comunque:

In cella F2 ho un valore calcolato con MAX(E:E)
in H2 vorrei avere il valore presente nella cella di colonna A
stessa cosa per i valori di H3 ed H4

In F5 vorrei avere il massimo calo assoluto. Pero' se inserisco =MAX(F10:F199) non ottengo 3,700 come immagino ma 1,900 e non capisco perchè ...

Nelle celle G4 e G5 ho inserito le formule proposte nel mio precedente post, ma il risultato non è quello voluto ....

Nelle celle gialle di colonna G ed H vorrei avere i cali settimanali e mensili (immaginavo di calcolarli verificando il giorno (lunedi) ed il mese ma poi non so come andare avanti ...

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: Excel 2010: riferimenti a celle

Postdi karug64 » 09/02/14 23:48

Aggiornamento :
Scopiazzando qua e la' ho risolto la parte riguardante le celle della testata (ma ho dovuto avvalorare le celle che erano vuote tra quelle piene)


Codice: Seleziona tutto
H2 =INDIRETTO("a"&RIF.RIGA(INDIRETTO("e" & CONFRONTA(MAX(E:E);E:E; 0))))

Codice: Seleziona tutto
H3 =INDIRETTO("a"&RIF.RIGA(INDIRETTO("e" & CONFRONTA(MIN(E:E);E:E; 0))))

Codice: Seleziona tutto
H4 =INDIRETTO("a"&RIF.RIGA((INDICE(E11:E400;CONTA.VALORI(E11:E4000)))))

Codice: Seleziona tutto
H5=SE(ASS(MIN(F10:F4000)) > MAX(F10:F4000); INDIRETTO("a"&RIF.RIGA(INDIRETTO("e" & CONFRONTA(MIN(E10:E4000);E:E; 0)))); INDIRETTO("a"&RIF.RIGA(INDIRETTO("e" & CONFRONTA(MAX(E10:E4000);E:E; 0)))))


Il massimo calo dall'inizio l'ho calcolato cosi':

Codice: Seleziona tutto
=E10-(INDICE(E11:E400;CONTA.VALORI(E11:E4000)))


Il massimo calo assoluto invece cosi':

Codice: Seleziona tutto
=SE(ASS(MIN(F10:F4000)) > MAX(F10:F4000); (MIN(F10:F4000)*-1); MAX(F10:F4000))


Ora mi resta da risolvere gli scarti settimanali e mensili.
Spero possiate aiutarmi.

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: Excel 2010: riferimenti a celle

Postdi Anthony47 » 10/02/14 01:30

Calcoli il dato in I2 (hai scritti H2, ma sul foglio e' indicato I2) con
Codice: Seleziona tutto
=INDICE(A:A;CONFRONTA(G2;E:E;0))

Puoi copiare I2 in I3 (hai scritto H3) per il secondo risultato.
Non ho capito i calcoli fatti in G4 e G5, ma e' possibile che anche qui puoi riciclare la formula copiandola da I2.

Se vuoi calcolare il massimo calo (calo calcolato in colonna F) allora devi cercare il MINIMO, non il massimo: =MIN(F:F)

Per i calcoli settimanali, in una colonna calcolati il numero settimana della data in colonna A; io l' ho fatto in colonna L usando in L10 la formula
Codice: Seleziona tutto
=NUM.SETTIMANA(A10;2)
da copiare poi verso il basso.

Poi in G10 calcoli a ogni cambio di settimana la diferenza tra la media della settimana precedente rispetto alla meda della settimana corrente, con la formula
Codice: Seleziona tutto
=SE(L10<>L9;MEDIA(SE(($L$10:$L$1000=L9)*($E$10:$E$1000<>"");$E$10:$E$1000;""))-MEDIA(SE(($L$10:$L$1000=L10)*($E$10:$E$1000<>"");$E$10:$E$1000;""));"")

Da confermare con Contr-Maiusc-Enter, non il solo Enter; poi copia verso il basso.

Per il calcolo mensile userai una colonna in cui calcolerai il mese e poi una formula analoga, che fccia pero' riferimento alla colonna del mese.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel 2010: riferimenti a celle

Postdi karug64 » 10/02/14 21:28

Ciao. Innanzitutto grazie per la risposta.
Non mi è chiara pero' l'ultima formula proposta (MEDIA matriciale)
Ti faccio un esempio :
104,200 Lunedì
103,100
102,600
102,400
102,000
102,200
102,200
102,200 Lunedì

il risultato ottenuto 0,557

ma a cosa equivale ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: Excel 2010: riferimenti a celle

Postdi karug64 » 10/02/14 22:19

Scusa . Capito .
Ok
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: Excel 2010: riferimenti a celle

Postdi Anthony47 » 11/02/14 00:58

La formula fa la differenza tra la media "della settimana prima" e la media "della settimana dopo".

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel 2010: riferimenti a celle":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti