Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel 2007] Modificatore (?) in base a determinate celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel 2007] Modificatore (?) in base a determinate celle

Postdi contiend » 01/02/14 09:45

Gentilissimi esperti del forum.
Intanto mi scuso anticipatamente, ma non avevo idea di come chiamare questo thread!!

Sto cercando di produrre un "modificatore di difesa" che segue queste regole:


Se nella colonna E, ci sono MINIMO 4 lettere " D "
che hanno un voto (DIVERSO da una CELLA VUOTA) (il voto potrebbe anche essere ZERO) nella colonna J
e la media dei voti nella colonna J (corrispondente alle lettere " D " ) è tra 6,00 e 6,99
il risultato da inserire in cella L1, dovrà essere " 2 "


Con le stesse regole devo crearne una per la media voto sotto il 5,99 compreso = che mi da " 1 "


E l'ultima con una media voto sopra il 7 compreso = che mi da " 3 "


Immagine

Immagino sia complicata. Riuscite a darmi una mano?

Grazie dell'attenzione.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi wallace&gromit » 01/02/14 11:09

prova con questa formula matriciale
Codice: Seleziona tutto
=SE(SE(MATR.SOMMA.PRODOTTO(SE(D5:D30="D";1;0);SE(J5:J30>0;1;0))>=4;MEDIA(SE(D5:D30="D";SE(J5:J30>0;J5:J30)));0)<6;1;SE(SE(MATR.SOMMA.PRODOTTO(SE(D5:D30="D";1;0);SE(J5:J30>0;1;0))>=4;MEDIA(SE(D5:D30="D";SE(J5:J30>0;J5:J30)));0)>7;3;2))

da 3 risultati: 1 2 o 3, era previsto anche 0 in caso che non ci fossero almeno 4 "D"?
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi contiend » 01/02/14 11:49

Intanto grazie della risposta, ma utilizzando il tuo codice mi da #VALORE!

http://we.tl/Gj2RX1riCC

Qui trovi il file.

da 3 risultati: 1 2 o 3, era previsto anche 0 in caso che non ci fossero almeno 4 "D"?

Si, in effetti hai ragione. Se ci sono 3 "D" o meno, il risultato dev'essere ZERO.

Grazie dell'aiuto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi Anthony47 » 01/02/14 15:21

Prova anche con
Codice: Seleziona tutto
=SE(SOMMA((E5:E24="D")*(J5:J24<>""))>3;SCEGLI(MAX(INT(MEDIA(SE(E5:E24="D";SE(J5:J24<>"";J5:J24;"");"")));1);1;1;1;1;1;2;3;3;3;3;3);0)

Da confermare con Contr-Maiusc-Enter, non il solo Enter.
Dovrebbe funzionare per valori della media fino a 11, spero i voti non arrivino a 30...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi contiend » 01/02/14 15:33

Funziona perfettamente.
Grazie mille del supporto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi contiend » 17/04/15 11:09

Anthony47 ha scritto:Prova anche con
Codice: Seleziona tutto
=SE(SOMMA((E5:E24="D")*(J5:J24<>""))>3;SCEGLI(MAX(INT(MEDIA(SE(E5:E24="D";SE(J5:J24<>"";J5:J24;"");"")));1);1;1;1;1;1;2;3;3;3;3;3);0)

Da confermare con Contr-Maiusc-Enter, non il solo Enter.
Dovrebbe funzionare per valori della media fino a 11, spero i voti non arrivino a 30...

Ciao


Ciao,
stavo cercando di modificare alcuni dati, ma non riesco a capire come fare! Ho fatto vari test ma tutti sono andati a "cestinare" :aaah

Le modifiche, rispettando sempre la base del primo thead
Se nella colonna E, ci sono MINIMO 4 lettere " D "
che hanno un voto (DIVERSO da una CELLA VUOTA) (il voto potrebbe anche essere ZERO) nella colonna J

della formula dovrebbero rispettare queste regole:

Se la media è INFERIORE o UGUALE a 6,09 = dovrà riportare 0,5
Se la media è TRA 6,10 (compreso) e 6,37 (compreso) = dovrà riportare 1,5
Se la media è SUPERIORE o UGUALE a 6,38 = dovrà riportare 3

Possibile?

Grazie dell'attenzione e dell'aiuto, come sempre! :oops:
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [excel 2007] Modificatore (?) in base a determinate cell

Postdi Anthony47 » 17/04/15 11:57

In questo caso prova con
Codice: Seleziona tutto
=SE(SOMMA((E5:E24="D")*(J5:J24<>""))>3;INDICE({0,5.1,5.3};CONFRONTA(MEDIA(SE(E5:E24="D";SE(J5:J24<>"";J5:J24;"");""));{0.6,091.6,371.99}));0)

Sempre Contr-Maiusc-Enter
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel 2007] Modificatore (?) in base a determinate celle":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti