Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Aiuto per una Macro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Aiuto per una Macro

Postdi verdemont » 31/01/14 18:18

Ciao a tutti

ho una base dati che va dalla colonna A ad N.
Inserendo dei filtri da P8 a X8 vorrei avere i risultati da Y8 a AA8.
Allego file di esempio:

https://www.dropbox.com/s/ngwbuheyqkfktkc/Esempio.xlsx

In particolare in P8 e in Q8 stabilisco l'anno da ricercare secondo la colonna B della base dati
In R8 e S8 il giorno della settimana secondo la colonna A della base dati.
In T8 e U8 il mese secondo la colonna C della base dati
In V8 e W8 il range delle quote seconde la colonna H della base dati
X8 rappresenta il pronostico giocato di cui alla colonna K della base dati: nel mio caso 1 ossia la vittoria della squadra di casa (colonna F).

Messi tutti i filtri di cui sopra vorrrei che in Y8 mi desse il totale del vinto secondo la colonna N della base dati. In Z8 vorrei avere il totale delle partite giocate secondo i filtri di cui sopra. In AA8 il totale delle partite vinte (ossia quando K=1 e L>M) sempre secondo i parametri immessi da P8 a X8.

Spero si capisca
Grazie
Verdemon
verdemont
Utente Junior
 
Post: 40
Iscritto il: 26/05/12 08:16

Sponsor
 

Re: Aiuto per una Macro

Postdi verdemont » 01/02/14 14:44

nessuno che mi sappia aiutare?

Con le formule ci sono risucito ma excel perde troppo tempo per fare i calcoli.
Con una macro sicuramente si risolve, ma sono a zero su questo.
Avrei bisogno si qulcuno che mi sappia dare un dritta su come impostare la macro.
Grazie ancora
Verdemont
verdemont
Utente Junior
 
Post: 40
Iscritto il: 26/05/12 08:16

Re: Aiuto per una Macro

Postdi Anthony47 » 01/02/14 19:49

Se non ho capito male, calcoli i "Giocati" (Z8) con la formula
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A10000>=R8);--(A1:A10000<=S8);--(B1:B10000>=P8);--(B1:B10000<=Q8);--(C1:C10000>=T8);--(C1:C10000<=U8);--(H1:H10000>=V8);--(H1:H10000<=W8);--(K1:K10000=X8))
Il "Vinto" (Y8) con
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A1:A10000>=R8);--(A1:A10000<=S8);--(B1:B10000>=P8);--(B1:B10000<=Q8);--(C1:C10000>=T8);--(C1:C10000<=U8);--(H1:H10000>=V8);--(H1:H10000<=W8);--(K1:K10000=X8);N1:N10000)

Non mi pare che queste formule, pronte per gestire 10mila righe, siano lunghe da calcolare.

Non ho invece capito il concetto di "Vinti" (AA8) per cui non so che calcoli fare; devi comunque "ampliare" la formula
inserita in Z8 per aggiungere, all' interno di MATR.SOMMA.PRODOTTO, ulteriori matrici che rappresentino i calcoli da fare per restituire il dato cercato; infatti la formula inserita in Z8 seleziona tutte le partite che rispondono ai criteri indicati in P8:X8.


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Aiuto per una Macro

Postdi verdemont » 02/02/14 11:49

Grazie Anthony, tutto chiaro. AA8 sono gli incontri che io ho "azzeccato" sulla base di quelli giocati. Sono in pratica quelli che hanno L>M quando K=1 e L<M quando K=2.

Con le formule però il foglio perde una sacco di tempo a restituirmi i valori. Mi chiedevo se invece con una macro VB non si potesse avere lo stesso risultato in maniera più veloce.

Grazie
verdemont
Utente Junior
 
Post: 40
Iscritto il: 26/05/12 08:16

Re: Aiuto per una Macro

Postdi Anthony47 » 02/02/14 19:26

Nei miei test il ricalcolo di ambedue le formule su un elenco lungo 10mila righe (ottenuto copiando verso il basso il contenuto del tuo file) richiede 2-2,5 centesimi di secondo; 1-1,5 cent sull' elenco di 3365 righe ma formule impostate fino a 10mila.
Una macro difficilmente potrebbe fare meglio.

Credo che ci sia qualcos'altro a rallentare il tuo file...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Aiuto per una Macro

Postdi verdemont » 03/02/14 17:59

Ciao Anthony

ho provato su un altro PC e funziona, è veloce.
Al momento il mio DB è quasi 9mila righe. Quando sarà troppo lento magari chiederò aiuto per le macro :-)

Grazie per tutto
Verdemont
verdemont
Utente Junior
 
Post: 40
Iscritto il: 26/05/12 08:16

Re: Aiuto per una Macro

Postdi Anthony47 » 04/02/14 22:44

Ok.
Ricorda che le formule sono predisposte solo per 10mila righe; puo' essere prudente aumentare tutti quei "10000" in 15000?

Ma quante formule di questo tipo hai, sul tuo foglio?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Aiuto per una Macro":

Aiuto urgente!!!
Autore: templare77
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Zer0Kelvin e 17 ospiti