Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Come calcolare il valore minimo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Come calcolare il valore minimo

Postdi evvivame » 30/01/14 23:44

Ciao !
Ho un foglio Excel di questo tipo:
..A B C.....
1 5 7 4
2 3 2 6
3 1 4 5

Vorrei costruire una formula che mi dica che
a. il valore minimo della riga 1 è 4 che si trova nella colonna C e
b. il valore minimo della riga 2 è 2 che si trova nella colonna B e
c. il valore minimo della riga 3 è 1 che si trova nella colonna A

(Pensate che nelle righe 1,2,3 ci siano prodotti e sulle colonne i relativi prezzi per i supermercati A,B,C)

Qualche mago di Office sa se si può fare ??
Graziee!!!!!!!!!!!!!!!
evvivame
Utente Senior
 
Post: 133
Iscritto il: 19/09/05 20:38

Sponsor
 

Re: [Excel] Come calcolare il valore minimo

Postdi ricky53 » 31/01/14 00:03

Ciao,
ipotizziamo che l'intervallo delle colonne sia "A:Z"
1. in "AA2" scrivi
Codice: Seleziona tutto
=MIN(A2:Z2)
per ottenere il minimo valore della riga "2"

2. in "AB2" scrivi
Codice: Seleziona tutto
=CODICE.CARATT(64+CONFRONTA(MIN(A2:Z2); A2:Z2; 0))
per ottenere la colonna ove il minimo si trova


Quanto suggerito al punto "2" vale se l'intervallo ha come colonna massima la "Z".
Se l'intervallo è maggiore si può avere il numero della colonna con la seguente formula
Codice: Seleziona tutto
CONFRONTA(MIN(A2:CZ2); A2:CZ2; 0)

Qui l'intervallo delle colonne è "A:CZ".
Per avere la lettera ... non mi viene una soluzione con formule che sia semplice.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Come calcolare il valore minimo

Postdi ricky53 » 31/01/14 00:45

Ciao,
cercando comunque di trovare una soluzione non molto complessa ...
in una cella di appoggio "DB2" si scrive la formula già proposta
Codice: Seleziona tutto
CONFRONTA(MIN(A2:CZ2); A2:CZ2; 0)

e in "DC2" si scrive la formula seguente
Codice: Seleziona tutto
=SE(INT(DB2/26)>0; CODICE.CARATT(64+INT(DB2/26)); "") & CODICE.CARATT(64 + DB2 - INT(DB2 / 26) * 26)


Ovviamente ... in attesa di qualche altro utente che proponga qualcosa di più semplice !!!
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Come calcolare il valore minimo

Postdi Anthony47 » 31/01/14 00:53

A scopo puramente ludico, se il numero colonna e' in DB2 la parte letterale e' risolvibile con
Codice: Seleziona tutto
=SOSTITUISCI(INDIRIZZO(1;DB2;4);"1";"")

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Come calcolare il valore minimo

Postdi ricky53 » 31/01/14 01:25

Ciao Anthony,
ottima soluzione !!!
Semplice al massimo ma ... molto potente.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Come calcolare il valore minimo

Postdi wallace&gromit » 31/01/14 08:45

chiedo scusa a Ricky e Anthony per il mio ardire, ma penso che siete andati un po' troppo in là.
Immagino che evvivame vorrebbe elencato in ogni riga il nome del supermercato più conveniente (il cui elenco immagino sia in riga 1)
a quel punto basta questa formula:
Codice: Seleziona tutto
=INDICE(A$1:Z$1;CONFRONTA(MIN(A2:Z2);A2:Z2;0))
dove Z può essere sostituito con qualsiasi indicatore di colonna (anche solo C se i supermercati sono 3).
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: [Excel] Come calcolare il valore minimo

Postdi ricky53 » 31/01/14 11:18

Ciao,
rileggendo meglio (a parte che non è molto chiaro ciò che descrive "evvivame" e che il titolo potrebbe ingannare) probabilmente W&G ha ragione ...
Attendiamo la rispsota di "evvivame"


Comunque vada Anthony ha fornito un'ottima FORMULA che ha un grosso valore didattico ... che potrà essere utile ad altri navigatori del nostro forum e NON SOLO
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Come calcolare il valore minimo

Postdi ninai » 31/01/14 19:28

Ciao
A proposito di valore didattico, la formula di Anthony (bravo!!), potrebbe essere usata per restituire la lettera di qualunque colonna nella quale ci troviamo e/o ci riferiamo:
Codice: Seleziona tutto
=SOSTITUISCI(INDIRIZZO(1;RIF.COLONNA();4);"1";"")
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: [Excel] Come calcolare il valore minimo

Postdi Anthony47 » 02/02/14 20:03

Sono grato per l' entusiasmo che ha provocato la formula pubblicata con scopi puramente ludici; nella pratica pero' quel "virtuosismo" non e' di nessuna utilita'...

Sono anche io convinto che w&g ha colto meglio l' esigenza dell' utente.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Come calcolare il valore minimo":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti

cron