Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Libreoffice]Importare celle da un altro file

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Libreoffice]Importare celle da un altro file

Postdi MastroLube » 21/01/14 16:34

Buongiorno a tutti!

Avrei una domanda da porvi..

E' da un po' che cerco una soluzione ma non riesco a trovarla.

Dovrei importare delle determinate celle da un altro file excel in quello aperto senza impazzire.

In pratica la macro dovrebbe cercare in una certa colonna un numero per poi andarlo a cercare nell'altro file. Se lo trova deve prendere una casella della riga corrispondente a dove trova il numero e incollarla nella cella vicino a quella di partenza.

Come si può fare? Qualcuno ha voglia di darmi qualche dritta?

Grazie mille!!

Dennis

PS: uso libreoffice, ultima versione.
MastroLube
Newbie
 
Post: 2
Iscritto il: 21/01/14 16:29

Sponsor
 

Re: [Libreoffice]Importare celle da un altro file

Postdi Anthony47 » 23/01/14 02:00

Ciao MastroLube, benvenuto nel forum.
La cosa piu' semplice e' che apri anche il file2 al cui interno devi cercare il valore, poi nel file1 imposti un Cerca.Vert. Ad esempio guarda questa formula:
Codice: Seleziona tutto
=CERCA.VERT(A2;[MULTI_B40121.xlsm]Foglio1!$A:$E;3;0)
Essa vai su file MULTI_B40121.xlsm (che deve essere aperto), cerca in colonna A di Foglio1 il valore presente in A2 del foglio in cui inserisci la formula; se lo trova importa il valore presente in colonna C (la colonna "3" dell' intervallo $A:$E), se non lo trova riporta l' errore #N/D.

Questo funziona su Excel, penso che libreOffice sia pienamente compatibile nell' uso delle funzioni.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Libreoffice]Importare celle da un altro file":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti