Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel: formula con se nidificati e non solo...

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel: formula con se nidificati e non solo...

Postdi karug64 » 19/01/14 17:28

Salve a tutti.
Nel foglio di calcolo che sto compilando ho necessita di scrivere su una cella (B2) un valore in base al valore presente nella cella A2. questo valore puo' essere:

Sottopeso < 18.5
Normopeso da 18.5 a 24.9
Sovrappeso da 25.0 a 29.9
Obesità di classe I (moderata) da 30.0 a 34.9
Obesità di classe II da 35.0 a 39.9
Obesità di classe III BMI > 40

Quindi dovrei controllare A2 e se < 18,5 scrivere in B2 sottopeso, se compreso tra 18m5 e 24,9 Normopeso ecc. ecc.

E' fattibile ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel: formula con se nidificati e non solo...

Postdi wallace&gromit » 19/01/14 18:45

questo genere di confronti si risolve meglio con un cerca.vert() che con i se annidati.
In uno spazio libero del tuo foglio crei la tabella delle equivalenze con in prima colonna i valori (0/18.5/25/30/35/40)
e nella seconda colonna le diciture (sottopeso/...)
in B2 inserisci
Codice: Seleziona tutto
=cerca.vert(A2;*riferimento a tabella* ;2)

i valori intermedi saranno attribuiti sempre per difetto alla categoria corrispondente dell'elenco
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel: formula con se nidificati e non solo...

Postdi cd7019 » 19/01/14 22:00

=SE(A2<18,5;"Sottopeso";SE(A2<25;"Normopeso";SE(A2<30;"Sovrappeso";SE(A2<35;"Obesità di classe I (moderata)";SE(A2<40;"Obesità di classe II";"Obesità di classe III")))))

ciao
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Re: excel: formula con se nidificati e non solo...

Postdi karug64 » 19/01/14 22:27

Ok. Entrambe le soluzioni vanno bene (ovviamente).
Il problema si pone quando nella cella A(x) non c'e nessun valore (ma questa formula : =SE(E17<>0;(E17/(1,84*1,84));"")
In questo caso la soluzione proposta da wallace&gromit da come valore nella cella #N/D, mentre quella di cd7019 da come risultato "Obesità di III classe) ovvero il maggiore.

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: excel: formula con se nidificati e non solo...

Postdi cd7019 » 19/01/14 22:33

=SE(A2>0;SE(A2<18,5;"Sottopeso";SE(A2<25;"Normopeso";SE(A2<30;"Sovrappeso";SE(A2<35;"Obesità di classe I (moderata)";SE(A2<40;"Obesità di classe II";"Obesità di classe III")))));"")
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Re: excel: formula con se nidificati e non solo...

Postdi karug64 » 19/01/14 22:36

cd7019 ha scritto:=SE(A2>0;SE(A2<18,5;"Sottopeso";SE(A2<25;"Normopeso";SE(A2<30;"Sovrappeso";SE(A2<35;"Obesità di classe I (moderata)";SE(A2<40;"Obesità di classe II";"Obesità di classe III")))));"")


Mi spiace ma non funziona. Continua a darmi obesit' di III ...

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: excel: formula con se nidificati e non solo...

Postdi cd7019 » 19/01/14 22:43

Sul mio excel funziona.
Strano.
devo inserire il n° nella cella A2

forse abbiamo la formattazione dei decimali diversa "," con "."
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Re: excel: formula con se nidificati e non solo...

Postdi karug64 » 19/01/14 22:52

Ok.
Allo stato attuale ho risolto con la prima soluzione (cerca.vert) sostituendo la formula cosi:

Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT(G6;$T$6:$U$11;2));"";(CERCA.VERT(G6;$T$6:$U$11;2)))


e funziona.

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: excel: formula con se nidificati e non solo...

Postdi cd7019 » 19/01/14 22:53

forse ho capito.
hai inserito lo spazio nella cella A2.
formatta la cella in modo da inserire solo numeri.

ciao
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38


Torna a Applicazioni Office Windows


Topic correlati a "excel: formula con se nidificati e non solo...":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti

cron