Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Marco/Pivot per ogni elemento di un filtro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Marco/Pivot per ogni elemento di un filtro

Postdi Dylan666 » 13/01/14 16:49

Salve a tutti, ho un foglio excel dove ho messo i filtri automatici sulla prima riga che infatti contiene il nome delle varie colonne.
A questo punto ho filtrato per la colonna E per un certo singolo valore che mi ha ovviamente escluso tutti gli altri.

Mantenendo quel primo filtro fisso ho una seconda colonna chiamata D dove anche ì il filtro mi ha raggruppato tutte le righe contenenti valori simili.

Sono degli ID e io per ognuno dovrei trascrivere su un secondo foglio dei calcoli.

Es:
=SUBTOTALE(9;ATT!AZ2:AZ6000)

Se nella colonna D ho per esempio 10 valori dovrei cambiare ogni volta il filtro, selezionare solo la prima voce (tutte le altre no), vedere quanto viene il subtotale e segnarlo ad esempio nella colonna A di un secondo foglio.

Poi dovrei spostare il filtro, selezionare solo la seconda voce, calcolate il subtotale e metterlo nella colonna B e così via.

Esiste un maniera per fare tutto in automatico?

Grazie anticipatamente
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Sponsor
 

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi ricky53 » 13/01/14 19:05

Ciao,
al volo direi una PIVOT è immediata e dinamica ma senza vedere i dati ...

Si può avere un file di esempio, senza dati riservati?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi Dylan666 » 14/01/14 11:32

Purtoppo sarebe un lavoraccio, ma se ho tempo ci provo.
Semplifico la domanda:
Abbiamo una tabella di due colonne così formata:

Codice: Seleziona tutto
      A         |      B   
      ANIMALI   |      Quantità
      Cani      |      5
      Gatti     |      6   
      Gatti     |      2
      Cani      |      5
      Topi      |      7
      Gatti     |      2
      Topi      |      5


Come posso mettere in un nuovo foglio in A1 la somma dei Gatti, in B1 quella dei Cani e in C1 quella dei topi senza dover usare tre voltre i filtri e il subtotale per fare la somma?

Nel caso reale gli "animali" sono molto di più e le colonne "quantità" sono 5 o 6
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi ricky53 » 14/01/14 13:38

Ciao,
usa una pivot e ne esci.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi Dylan666 » 14/01/14 14:32

Mi spieghi brevemente come?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi wallace&gromit » 14/01/14 14:39

se le colonne con le quantità sono parecchie con la pivot forse non è così comodo, ma non puoi introdurre una colonna di riepilogo in B, che somma tutte le eventuali quantità che si trovano nelle colonne successive? (immagino che in riga 2 ci saranno solo quantità che si riferiscono a "cani" e in riga 3 "gatti", ecc. quindi la somma vale sempre).
A quel punto puoi fare la pivot, oppure la formula
Codice: Seleziona tutto
=SOMMA.SE(Foglio1!$A:$A;Foglio2!B$1;Foglio1!$B:$B)

dove da B1 a destra nel foglio2 c'è l'elenco di categorie di animali.

Se non puoi creare la colonna riassuntiva pensavo a qualcosa con una formula matriciale (che forse si può semplificare)
Codice: Seleziona tutto
=SOMMA(SE(Foglio1!A2:A10000=Foglio2!A1;Foglio1!B2:B10000)+SE(Foglio1!A2:A10000=Foglio2!A1;Foglio1!C2:C10000)+SE(Foglio1!A2:A10000=Foglio2!A1;Foglio1!D2:D10000)+SE(Foglio1!A2:A10000=Foglio2!A1;Foglio1!E2:E10000)+SE(Foglio1!A2:A10000=Foglio2!A1;Foglio1!F2:F10000))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi Dylan666 » 14/01/14 17:12

Ho risolto con la Pivot.
Il primo campo da filtrare (quello della colonna E) l'ho messo in "Filtro rapporto"
I valori di cui volevo fare il cliclo spostando il filtro (colonna D) sono stati messi in "Etichette riga"
I campi su cui fare i subtotali (es. AZ) li h messi come "Valori" (di riga) con "Impostazioni campo valore" su "Somma".
Poi a lato o fatto gli ulteriori calcoli

Grazie
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: [Excel] Marco/Pivot per ogni elemento di un filtro

Postdi ricky53 » 14/01/14 17:56

Ciao,
sorry, non ero disponibile prima ... vedo con piacere che hai risolto.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Marco/Pivot per ogni elemento di un filtro":


Chi c’è in linea

Visitano il forum: Francesco6918, patel e 6 ospiti