Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

CORREZIONE FORMULA

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

CORREZIONE FORMULA

Postdi Lucio Peruggini » 30/11/13 00:36

Ciao a tutti

Non ricordo chi aveva fatto questa formula che mi permette di ottenere cinque numeri estrapolati da una sola cella (colonna C8) che vanno poi separati in cinque celle diverse e affiancate (colonne v-w-x-y-z) stessa riga.

https://dl.dropboxusercontent.com/u/182 ... IZIONE.PNG

La formula inserita in V8 che poi trascino verso destra, è questa:

=STRINGA.ESTRAI($C6;1+RIF.COLONNA(A$1)*3-3;2)

Visibile anche dall’immagine.

Essa è perfettamente funzionante ammesso che i numeri inseriti nella colonna “C” siano a due cifre.

Ora avrei la necessità d’inserire sempre separatamente in (v-w-x-y-z) la medesima cinquina della colonna (C) che purtroppo ha numeri misti; di due cifre e anche di una sola cifra.
In questo caso la formula non va bene; come si può fare?

In pratica vorrei ottenere la medesima cinquina così com’è (con una e due cifre) sulle cinque celle separate.

Si noterà per l’appunto che le celle della riga otto, colonne v-w-x-y-z hanno come restituzione della formula “7.1.1.8.1” ma dovrei avere: 7-11-51-58-81.

Ciao e grazie.
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Sponsor
 

Re: CORREZIONE FORMULA

Postdi CANAPONE » 30/11/13 05:22

Ciao,

lavorando con stringhe di numeri divisi da un un punto tipo 70.88.99.1.8

Codice: Seleziona tutto
=SE(RIF.COLONNA(A$1)<6;STRINGA.ESTRAI(SOSTITUISCI($C6;]".";RIPETI(" ";20));1+RIF.COLONNA(A$1)*20-20;10)+0;"")



---------------------

Se lavori invece con stringhe 1-50-77-80-55

Codice: Seleziona tutto
=SE(RIF.COLONNA(A$1)<6;STRINGA.ESTRAI(SOSTITUISCI($C6;"-";RIPETI(" ";20));1+RIF.COLONNA(A$1)*20-20;10)+0;"")


Il <6 blocca l'estrazione al quinto numero.


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: CORREZIONE FORMULA

Postdi Lucio Peruggini » 30/11/13 13:22

Canapone GRAZIE MOLTE!!! Funziona perfettamente.
La stringa è composta da numeri separati dal (.), l'altra potrà sempre tornare utile.

Nella prima formula ti è scappata una parentesi quadra di troppo (SOSTITUISCI($C6;]"."

Grazie ancora per l'aiuto e buona giornata
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Re: CORREZIONE FORMULA

Postdi siron277 » 13/01/14 16:09

Ciao a tutti.
Ho trovato questa formula utile, ora se è possibile avrei il problema inverso.
Ho nella cella A1 il numero 10, B1 il numero 35 e in C1 il numero 84.
Se è possibile vorrei inserirli nella cella F1 nel modo 10-35-84

Grazie mille

Noris
Win10 + Office 2010 Ita
siron277
Utente Junior
 
Post: 50
Iscritto il: 27/10/13 14:38

Re: CORREZIONE FORMULA

Postdi Statix » 13/01/14 17:25

in F1
=A1&"-"&B1&"-"&C1
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: CORREZIONE FORMULA

Postdi siron277 » 13/01/14 23:34

Ciao Statix,
E' ok!! ;)
Grazie mille.

Noris
Win10 + Office 2010 Ita
siron277
Utente Junior
 
Post: 50
Iscritto il: 27/10/13 14:38


Torna a Applicazioni Office Windows


Topic correlati a "CORREZIONE FORMULA":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti