Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] verifica valori uguali

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] verifica valori uguali

Postdi nat » 22/11/13 12:15

Salve,
ho un problema con i fogli di calcolo (nello specifico open office), ho controllato anche con il cerca nel forum, ma non sono riuscita a trovare quello che mi necessitava e allora vi chiedo aiuto.
LA mia situazione è questa: ho, in due fogli divesi, dei valori nelle colonne A, B, C e ho bisogno di sapere se per ogni valore presente nella colonna A il corrispondente valore presente nella colonna B e C sia uguale nei due fogli (il valore della colonna A è uguale nei due fogli).
I valori della colonna A non sono nello stesso ordine nei due fogli.
Banalmente ho da verificare se quello che ho inserito (foglio 1 estratto dal DB) è uguale a quello che dovevo inserire (foglio 2).
Potete aiutarmi?
Grazie
NAt
nat
Newbie
 
Post: 4
Iscritto il: 22/11/13 11:49

Sponsor
 

Re: [excel] verifica valori uguali

Postdi CANAPONE » 22/11/13 13:49

Ciao,

se vai nel secondo foglio, con un cerca.vert puoi confrontare i dati corrispondenti della seconda e terza colonna

Codice: Seleziona tutto
=CERCA.VERT($A2;Foglio1.$A$2:$C$1000;2;0)=B2


Codice: Seleziona tutto
=CERCA.VERT($A2;Foglio1.$A$2:$C$1000;3;0)=C2


Se le formule rispondono con FALSO i dati non sono uguali


Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel] verifica valori uguali

Postdi nat » 25/11/13 07:53

Grazie Canapone,
usavo il cerca.vert per riportarmi i valori sul secondo foglio....non avevo pensato ad usare la formula in questo modo...Grazie!
Nat
nat
Newbie
 
Post: 4
Iscritto il: 22/11/13 11:49

Re: [excel] verifica valori uguali

Postdi nat » 25/11/13 08:09

Salve,
ho utilizzato la formula che diventa:
=CERCA.VERT(B105;'L 228'.C1:E210;2;0)= D105
dove B105= A1
da c1 a e210 è la mia matrice presente nel primo foglio (L228)
e d105 = B1
ma mi restituisce tutti Falso...secondo me perchè il valore presente in D105 ha 10 decimali mentre il valore presente nella matrice ha 17 decimali quindi non sono valori uguali.... ho provato a formattare la colonna del foglio 1 con 10 decimali ma non me li modifica...
Consigli??
nat
Newbie
 
Post: 4
Iscritto il: 22/11/13 11:49

Re: [excel] verifica valori uguali

Postdi wallace&gromit » 25/11/13 09:56

la formattazione non incide sul valore contenuto nella cella,
devi usare =arrotonda(xxx;10) per avere l'arrotondamento a 10 decimali
però rischi che se nell'altro caso il valore era troncato in modo diverso dall'arrotondamento essi non coincideranno neppure ora.

inoltre per farla funzionare, io dovrei scrivere la formula così:
=CERCA.VERT(B105;L 228!C1:E210;2;0)= D105
ma magari dipende dalla differente versione di excel?
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [excel] verifica valori uguali

Postdi Anthony47 » 25/11/13 23:44

Evidentemente non devi cercare se i valori sono "uguali" ma se sono "approssimativamente uguali", usando la funzione Arrotonda, come suggerito da w&g; ad esempio:
Codice: Seleziona tutto
=ARROTONDA(CERCA.VERT(A7;Foglio5!A$1:C$100;3;0);4)=ARROTONDA(B7;4)
Colonna B del primo foglio controllata rispetto a colonna C del secondo foglio (Foglio5, nel mio test), con arrotondamento a 4 decimali

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] verifica valori uguali

Postdi nat » 03/12/13 08:12

ok grazie!!!
nat
Newbie
 
Post: 4
Iscritto il: 22/11/13 11:49


Torna a Applicazioni Office Windows


Topic correlati a "[excel] verifica valori uguali":


Chi c’è in linea

Visitano il forum: fabrizio2001 e 15 ospiti