Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Valore da cella a formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Valore da cella a formula

Postdi nobile66 » 13/11/13 09:16

Salve, avrei bisogno di un aiuto , nello specifico io ho
In cella R6 una formula =CONTA.SE(Z11:Z1000;"=1,65")
io vorrei che in cella Z6 quando inserisco un valore ( 1,65-1,70-1,80 ecc )mi si vada a modificare il valore nella formula in cella R6
Ringrazio anticipatamente
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Sponsor
 

Re: Valore da cella a formula

Postdi Anthony47 » 13/11/13 09:49

Benvenuto nel forum.

Prova
Codice: Seleziona tutto
=CONTA.SE(Z11:Z1000;Z6)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Valore da cella a formula

Postdi nobile66 » 13/11/13 10:04

Ok grazie , funziona
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 13/11/13 10:09

Aiutino grazie ,
nella colonna sempre Z11:Z1000
vorrei che le celle col valore immesso nella cella Z6 si colorasse di verde
Grazie anticipatamente
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 13/11/13 18:30

Pero' se la formula metto =CONTA.SE(O15:O979;">=R3")-CONTA.SE(O15:O979;">=S3") in cella R5 mi da 0 invece di darmi il totale nello specifico
R3 = 1.50
S3 = 1.80
NELLA COLONNA O15 - O979 CI SONO UNA SERIE DI VALORI CHE VANNO DA 1.50A 1.80 E QUINDI DOVREBBE METTERE QUEL TOTALE,INVECE MI DA 0
Ringrazio anticipatamente
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi ninai » 13/11/13 19:45

Ciao
prova
=CONTA.SE(O15:O979;">="&R3)-CONTA.SE(O15:O979;">="&S3)

così 1,50 è incluso e 1,8 è escluso
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Valore da cella a formula

Postdi nobile66 » 14/11/13 08:10

Ciaooo grazie , ci siamo , ma non si riesce a includere anche 1,80 ?
Ringrazio anticipatamente
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi ninai » 14/11/13 18:23

Ciao
certo!!
basta modificare il secondo ">=" in ">"

=CONTA.SE(O15:O979;">="&R3)-CONTA.SE(O15:O979;">"&S3)

Ma scusa, l'hai proposta tu la formula!! non l'avevi capita???
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Valore da cella a formula

Postdi nobile66 » 09/01/14 08:31

Grazie..
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 09/01/14 09:03

Salve sempre riguardo formule :
allora io ho 3 celle ( B.M.A vuote )....... poi altre tre celle con dei valori variabili es: ( 1.50; 2.50; 4.00 )...... e una cella con es: ( o 1; o X; o 2 ) allora , se nella cella dove ci sara' ( 1oXo2 ) ce 1 ; mi deve mettere 1 nella cella ( B ) perché e Valore più basso degli altri 2 ( 1.50; 2.50; 4.00 ) ; se ce X mi deve mettere 1 nella cella ( M ) perché e Valore più alto del Primo e del Terzo ( 1.50; 2.50; 4.00 ) se ce 2 mi deve mettere 1 nella cella ( A ) perché il Valore e' il più alto dei 3 ( 1.50; 2.50; 4.00 ).
Il B,M,A sarebbe Bassa, Media , Alta . quindi i Vaolri ( 1.50; 2.50; 4.00 ) potrebbero essere inverti o diversi : ( 2.00 ;1.25;3.50) o ( 4.00; 3.00; 1.50) .
Grazie
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi Anthony47 » 09/01/14 12:20

In excel si possono scrivere Formule che usano Funzioni applicate a Celle; poiche' quali sono le celle in gioco non e' stato descritto posso provare a scrivere delle formule con solo con le funzioni, lasciando XXX le celle a cui si applicano:
in B: =SE(E(XXX=1;MIN(XXX)=XXX);1;"")
in M: =SE(E(XXX="x";MIN(XXX)=XXX);1;"")
in A: =SE(E(XXX=2;MIN(XXX)=XXX);1;"")

Se con questo spunto non risolvi allora posta ancora scrivendo pero' anche quali sono le coordinate delle celle in gioco.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Valore da cella a formula

Postdi nobile66 » 09/01/14 15:31

Grazie , adesso provo !
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 09/01/14 16:08

Ciao non mi da errore ma nemmeno mi rida' nessun valore nelle caselle B M A..
allora la cella B e' la E29 ; la cella M e' la E30 ; la cella A e' la E31
le celle con i valori variabili , possono essere anche il primo maggiore del secondo e del terzo ( 3.00 2.00 1.50 )
e sono le celle Z35 , AA35, AB35 ;
e la cella dove ci puo' essere 1, x , 2 , e' la cella G35;
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 09/01/14 16:16

Quindi se esce 1 cella G35 e' il valore più alto dei 3 ( 3.00 2.00 1.50 ) e mi deve riportare 1 nella cella A che e' la E31
se esce 2 cella G35 e' il valore più basso mi deve mettere 1 nella cella E29
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi Anthony47 » 10/01/14 00:01

Riletto con i "chiarimenti" aggiuntivi mi e' venuto ancor di piu' mal di testa...

Poi per un attimo ho visto una luce che diceva che forse la formula magica potrebbe essere
Codice: Seleziona tutto
=--(RANGO(SE($G$35=1;$Z$35;SE($G$35="x";$AA$35;$AB$35));$Z$35:$AB$35)=4-RIF.RIGA(A1))

Da inserire in G29 e copiare poi in G30:G31.

Mi avanza solo la forza per mormorare "ciao"
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Valore da cella a formula

Postdi ninai » 10/01/14 07:39

Scusa la mia osservazione:

ricevi degli aiuti il 14/11/2013, dai riscontro ( o quasi) il 09/01/14, giusto perchè devi chiedere altri aiuti, non ti sembra di usarci tipo jukebox ???
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Valore da cella a formula

Postdi nobile66 » 10/01/14 08:58

Grazie dell' impegno , mi dispiace per il mal di testa causato !!
Siamo vicini ma non ok !
il ritorno nella cella G30 e G31 va bene ma la G29 quando il valore e il più basso non mi da 1
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi nobile66 » 10/01/14 09:01

Anche se modifico i valori ( 2.50;1.25;1.10 ) non va piu' niente !| :-(
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Re: Valore da cella a formula

Postdi Flash30005 » 10/01/14 09:26

Credo che stia sbagliando qualcosa perché la formula funziona perfettamente
devi inserirla in E29 e trascinarla fino a E31
Immagine
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Valore da cella a formula

Postdi nobile66 » 10/01/14 11:43

ok ci siamo !!!!!!! :-)GRAZIE !!!!!
Pero' non e' finito e cioe'
in Z ;AA ; AB nelle righe 36,37,38,e avanti fino riga 1000 , ho altri valori e in G35 adesso ce il 2 ma nelle celle G36, G37 ecc. ci sara o1 ,o X , o 2
e nelle celle E 29 30 31 mi deve riportare quanti sono gli 1 gli 2 gli X in base sempre se e b m a ...
nobile66
Utente Junior
 
Post: 19
Iscritto il: 13/11/13 08:59

Prossimo

Torna a Applicazioni Office Windows


Topic correlati a "Valore da cella a formula":

Formula Rif.riga
Autore: salatony
Forum: Programmazione
Risposte: 0

Chi c’è in linea

Visitano il forum: PcBase e 13 ospiti