Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma.se e conteggio si più fogli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma.se e conteggio si più fogli

Postdi blunotte13 » 05/11/13 13:02

Ciao a tutti, ho un file in cui, tramite macro, creo un nuovo foglio, lo rinomino con il valore di una cella e lo metto come ultimo foglio. Il primo foglio del file si chiama "totali", in cui ovviamente con la formula somma.se riassumo i totali relativi delle voci che poi saranno riportate su ogni foglio aggiunto. Il problema è che non so come dire alla formula che deve includere nel conteggio tutti i fogli del file compreso l'ultimo che viene aggiunto.
Naturalmente, non conoscendo il linguaggio, ho provato a registrare la macro
Codice: Seleziona tutto
 Sheets(Array("totali", "prova1", "prova2")).Select
    Sheets("totali").Activate
    Range("B2").Select
    ActiveCell.FormulaR1C1 = "=SUMIF(prova1!R2C2:R32C2,RC1,prova1!R2C8:R32C8)"
    Range("B3").Select

che però non so come modificare per il mio uso. Le celle a cui si applica la formula sono sempre le stesse per ogni foglio
le voci da B2:B32, le cifre H2:H32.
Grazie a tutti per l'aiuto.
Alla prossima, ciao ciao !!


Excel 2007
blunotte13
Utente Senior
 
Post: 116
Iscritto il: 13/01/10 19:35

Sponsor
 

Re: Somma.se e conteggio si più fogli

Postdi Anthony47 » 06/11/13 01:09

Se vuoi sommare in A1 di Foglio1 tutte le celle A1 di Foglio2, Foglio3, Foglio4 (fogli contigui) la formula da usare e'
Codice: Seleziona tutto
=SOMMA(Foglio2:Foglio4!A1)
Questo riferimento si chiama "Riferimento 3D".

Quindi:
-lascia in fondo un foglio vuoto, es FoglioZZ.
-nel foglio "Totali" (che deve essere quello piu' a sx) imposta le formule che vanno dal secondo foglio (Foglio2?) all' ultimo (FoglioZZ); del tipo
Codice: Seleziona tutto
=Somma(Foglio2:FoglioZZ!B2:B32)

-fai in modo che la tua macro inserisca i nuovi fogli in penultima posizione, e automaticamente si ritroveranno nei calcoli fatti dalle formule.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma.se e conteggio si più fogli":


Chi c’è in linea

Visitano il forum: raimea e 7 ospiti