Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

calcolo mkensile buono pasto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

calcolo mkensile buono pasto

Postdi maverik677 » 31/10/13 16:36

ciao a tutti, devo fare il calcolo mensile del buno pasto vi spiego entroin ufficio alle 8.00 ed esco alle 17.30 se faccio questo orario posso usufuire del buono pasto se faccio un orario dieverso da questo aad esempio entro alle 8.00 ed esco alle 14.30 non devo usufruire del buono pasto ho applicato questa formula:

=SE(O(C3="";D3="");"";SE(D3-C3<"6";"Non Buono Pasto";SE(D3-C3>"6.00";"Buono Pasto")))

come mai quando supero le 6 ore non mi appare Buono pasto? dove sbagl
maverik677
Newbie
 
Post: 5
Iscritto il: 28/10/13 10:14

Sponsor
 

Re: calcolo mkensile buono pasto

Postdi CANAPONE » 31/10/13 16:44

Ciao,

condivido una prima risposta. Quando lavoro con le ore ho spesso dei problemi.

Per indicare 6 ore ho scritto 6/24. In C3 e D3 gli orari di entrata ed uscita.

Pasto se orario superiore a 6 ( 6 ore ed un minuto)


Codice: Seleziona tutto
=SE(O(C3="";D3="");"";SE(D3-C3<=6/24;"Non Buono Pasto";SE(D3-C3>6/24;"Buono Pasto")))


oppure usando

ORARIO(6;0;0)

Codice: Seleziona tutto
=SE(O(C3="";D3="");"";SE(D3-C3<=ORARIO(6;0;0);"Non Buono Pasto";SE(D3-C3>ORARIO(6;0;0);"Buono Pasto")))


Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: calcolo mkensile buono pasto

Postdi maverik677 » 31/10/13 18:01

ciao canapone , funziona la formula grazie.
maverik677
Newbie
 
Post: 5
Iscritto il: 28/10/13 10:14

Re: calcolo mkensile buono pasto

Postdi maverik677 » 03/11/13 11:41

CIao canpaone ti allego il file, per qule motivo quando inserisco un orario che mi comporta il totale delle ore lavorative 6 mi dà buono pasto la formula che ho applicato è quella che mi hai suggerito cioè la seguente:

=SE(C2="";"";SE(B2-A2>=6/24;"Buono pasto";SE(B2-A2<6/24;"Non Buono Pasto")))

Ecco il file : http://www.filedropper.com/4578
maverik677
Newbie
 
Post: 5
Iscritto il: 28/10/13 10:14

Re: calcolo mkensile buono pasto

Postdi CANAPONE » 03/11/13 12:02

Ciao,

forse aggiustando la condizione

=SE(C2="";"";SE(B2-A2>6/24;"Buono pasto";SE(B2-A2<=6/24;"Non Buono Pasto")))


=SE(C2="";"";SE(B2-A2>orario(6;0;0);"Buono pasto";SE(B2-A2<=orario(6;0;0);"Non Buono Pasto")))


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: calcolo mkensile buono pasto

Postdi maverik677 » 04/11/13 11:05

Ciao canapone ho provato ora tutto funziona .Che dirti grazie infinite.
maverik677
Newbie
 
Post: 5
Iscritto il: 28/10/13 10:14

Re: calcolo mkensile buono pasto

Postdi maverik677 » 08/01/14 11:11

Ciao a tutti. il file mi funziona bene. solo che volevo apportare delle modifiche alla formula, se prendo un giorno di ferie oppure di malattia mi deve fare in modo che non mi deve fare il buono pasto in precedenza ho usato questa formula :

=SE(O(C3="";D3="");"";SE(D3-C3>6/24;"Buono Pasto";SE(D3-C3<=6/24;"Non Buono Pasto")))

ora spuntando dal calendario in entrata la voce M senza spuntare 8.00 - 15.12 che mi dava il buono pasto a secondo dell'orario che andavo a svolgere. ho inserito nel foglio questi valori in entrata . 8.00, M, Ferie e in uscita lo stesso , ora voglio che al di là dell'orario che vado a svolgere mi deve dare lo stesso il buono pasto ovviamente sempre se supero l'orario e anche quando in entrata e in uscita spunto la lettera M o Ferie non mi deve calcolare il buono pasto si può fare ?

in pratica a questa formula =SE(O(C3="";D3="");"";SE(D3-C3>6/24;"Buono Pasto";SE(D3-C3<=6/24;"Non Buono Pasto")))
dovrei aggiungere M e Ferie.Grazie allego il file: http://www.filedropper.com/buonpasto1
maverik677
Newbie
 
Post: 5
Iscritto il: 28/10/13 10:14


Torna a Applicazioni Office Windows


Topic correlati a "calcolo mkensile buono pasto":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti