Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

conta corrispondenti per colonna

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

conta corrispondenti per colonna

Postdi marcoc » 16/10/13 21:36

salve a tutti,
semplificando al massimo il mio caso ho in colonna A e in colonna B, celle compilate con "X" o "Y", ad esempio:
col.A: X Y Y Y X X Y
col.B: Y Y Y X X Y X
mi servirebbe una formula che mi restituisca il numero di righe nella quale si ha corrispondenza (indipendentemente X=X o Y=Y), in questo caso, 3.
sapete aiutarmi?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: conta corrispondenti per colonna

Postdi Dylan666 » 16/10/13 21:50

In C1 scrivi questa formula e la trascini in basso fino all''altezza dell'ultima coppia di righe compilate di A e B (nel tuo esempio sarebbe la riga 7)
Codice: Seleziona tutto
=SE(A1=B1;1;0)


Alla fine fai la sommma della colonna C e saprai quante corrispondenze ci sono
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: conta corrispondenti per colonna

Postdi marcoc » 16/10/13 21:55

grazie, l'avevo pensato anche io ma il punto è che nel file originale ho molte colonne tipo la B che devo confrontare con la A, per cui cercavo una formula da mettere sopra ogni colonna
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: conta corrispondenti per colonna

Postdi ninai » 16/10/13 23:14

Ciao
es. dati A2:A8 e dati da confrontare in B,C,D ecc.
in B1:
=SOMMA(($A2:$A8=B2:B8)*1)
Matriciale
Da calibrare e trascinare a destra

oppure
=MATR.SOMMA.PRODOTTO(($A2:$A8=B2:B8)*1)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: conta corrispondenti per colonna

Postdi marcoc » 17/10/13 19:14

ho provato con entrambe ma mi dà risultati troppo alti, forse anche perché nelle altre colonne ci sono anche valori vuoti; si possono escludere i casi di celle vuote?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: conta corrispondenti per colonna

Postdi ninai » 18/10/13 11:31

=MATR.SOMMA.PRODOTTO(($A2:$A8<>"")*($A2:$A8=B2:B8)*1)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "conta corrispondenti per colonna":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti

cron