Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Problema con formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Problema con formula

Postdi Lucio Peruggini » 17/09/13 23:39

Gentilmente un aiuto, sto letteralmente rincretinendo con queste formule che finora sono sempre andate bene. :roll:
Non riesco più a farle funzionar con questo nuovo foglio “Schema”.
Colonne (D-E); dovrebbero darmi i risultati che si vedono in (M-N) ma,
1. Quando apro il foglio mi viene fuori una schermata che dice:
Impossibile calcolare la formula (riferimento circolare) ma non ho altri fogli aperti; allego immagine ma anche file completo.
In pratica, la colonna “D” somma quante volte è uscito il numero “X” con appartenenza alla ruota (colonna B foglio VE).

La colonna “E” restituisce il massimo ritardo che quel numero con riferimento sempre al foglio VE si trova nella colonna “E”.

https://dl.dropboxusercontent.com/u/182 ... Schema.PNG

https://dl.dropboxusercontent.com/u/182 ... EMA%20.zip

Grazie per l’aiuto
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Sponsor
 

Re: Problema con formula

Postdi ninai » 18/09/13 10:03

Ciao
il riferimento circolare è nella formula in E8:

=MAX((VE!G$8:G$25000)*(VE!B$8:B$25000=B8)*(VE!E$8:E$25000=E8))

le formule corrette potrebbero essere:
in D8: =MATR.SOMMA.PRODOTTO((VE!$B$8:$B$23952=B8)*(VE!$E$8:$E$23952=C8))
in E8: =MAX(SE((VE!$B$8:$B$23952=B8)*(VE!$C$8:$C$23952=C8);VE!$G$8:$G$23952))
la seconda Matriciale

ma non funzionano lo stesso, secondo me, ci deve essere qualche anomalia nei dati.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Problema con formula

Postdi ninai » 18/09/13 10:30

edit
correggo la seconda =MAX(SE((VE!$B$8:$B$23952=B8)*(VE!$E$8:$E$23952=C8);VE!$G$8:$G$23952))

allego file corretto
https://www.dropbox.com/s/wc7a91shl6r84 ... MA%20.xlsx

ho provato a ricopiare sulla colonna B il valore VE ed ha funzionato
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Problema con formula

Postdi ninai » 18/09/13 10:55

comunque, anche le tue formule funzionano, basta correggere E8 con C8 , renderle matriciali e riscrivere "VE" su B8:B97

=SOMMA((VE!B$8:B$25000=B8)*(VE!E$8:E$25000=C8))

=MAX((VE!G$8:G$25000)*(VE!B$8:B$25000=B8)*(VE!E$8:E$25000=C8))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Problema con formula

Postdi Lucio Peruggini » 18/09/13 11:15

Ciao ninai, innanzitutto grazie per l'aiuto senza del quale i tempi di ricerca per questi valori sarebbero stati insostenibili.
Quello che non capisco è il riferimento alla colonna "C" foglio VE. Questa colonna marca esclusivamente la posizione, in che modo centra con i valori di "E - G"?

Comunque l'importante è che funzionino, grazie molte.
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Re: Problema con formula

Postdi ninai » 18/09/13 11:51

ciao Lucio
non ti confondere
il riferimento è alla colonna C del foglio schema, sarebbe come scrivere:
=SOMMA((VE!B$8:B$25000=schema!B8)*(VE!E$8:E$25000=schema!C8))
ma quando la cella ricade nello stesso foglio dove risiede la formula, si omette il nome del foglio.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Problema con formula

Postdi Lucio Peruggini » 18/09/13 12:18

E' vero! Sono proprio una frana.
Grazie e buona giornata.
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23


Torna a Applicazioni Office Windows


Topic correlati a "Problema con formula":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti