Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Diversi Problemi dopo aver tentato di modificare F:\ con C:\

Risolvi qui i tuoi problemi legati a Windows '95, '98, ME, NT, 2000, XP, 2003, Vista...

Moderatori: -> EleKtrA <-, antoo69

Diversi Problemi dopo aver tentato di modificare F:\ con C:\

Postdi fasenderos » 27/11/10 11:01

Salve a tutti,
Premessa: ho fatto una caxxata....come al solito il 99% dei problemi con il PC si trovano tra la sedia ed il monitor :)

Allora avevo già installato AVG 9.0 e volevo installare AVG 2011, il problema è che l'installazione di AVG 2011 non andava a buon fine perchè mi dava come errore: "Unità c:\ non valida", infatti il mio disco non è in C:\, ma in F:\ (mai capito perchè)...
Allora googolando un po' ho trovato una guida che spiegava come modificare la lettera del disco da F:\ a C:\, utilizzando il programma "Registrar Registry Manager"...in poche parole la guida spiegava di lanciare il programma, fare un search della parola "F:\" e selezionare tutte le chiavi di registro trovate, e fare un replace con "C:\", riavvire ed il gioco era fatto....appunto il gioco è fatto, si ma fatto male...il PC arrivava alla scermata BLU di caricamento di Windows e si bloccava....fortunatamente avevo un'altra partizione con Ubuntu e da li sono riuscito ad accedere ai file di sistema di Windows e sostituire i file del registro di sistema in Windows\system32\config SAM, SECURITY, SOFTWARE, DEFAULT, SYSTEM, con quelli che si trovano nella cartella Windows\repair....

Bene ora il PC parte...ovviamente ho dovuto reinstallare tutti i Driver (Audio, video, wireless ecc..), molti dei programmai non funzionavano più e ho dovuto reinstallarli...Non tutti i programmi però ora funzionano, e che io sappia al momento sono: AVG e DeamonTools...Il .NetFramework invece non riesco proprio ad installarlo, perchè l'installazione mi restituisce un errore e di conseguenza non funziona neanche il Catalyst Control Center, che richiede NetFramework 2.0...

Finchè si tratta di Ubuntu, riesco un pochino a pacioccarci, ma Windows proprio no, quindi posto il Log di HijackThis e spero che qualcuno sappia aiutarmi:
Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 10.45.29, on 27/11/2010
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v8.00 (8.00.6001.18702)
Boot mode: Normal

Running processes:
F:\WINDOWS\System32\smss.exe
F:\WINDOWS\system32\winlogon.exe
F:\WINDOWS\system32\services.exe
F:\WINDOWS\system32\lsass.exe
F:\WINDOWS\system32\Ati2evxx.exe
F:\WINDOWS\system32\svchost.exe
F:\WINDOWS\System32\svchost.exe
F:\WINDOWS\system32\Ati2evxx.exe
F:\WINDOWS\system32\spoolsv.exe
F:\WINDOWS\Explorer.EXE
F:\WINDOWS\RTHDCPL.EXE
F:\WINDOWS\system32\ctfmon.exe
F:\Program Files\Onda Connection Manager\ONDA CONNECTION MANAGER.exe
F:\WINDOWS\system32\SupportAppXL\cdrom_mon.exe
F:\Program Files\Common Files\Intel\WirelessCommon\RegSrvc.exe
F:\Program Files\TeamViewer\Version5\TeamViewer_Service.exe
F:\Program Files\TeamViewer\Version5\TeamViewer.exe
F:\WINDOWS\system32\msiexec.exe
F:\Program Files\HiJackThis\Trend Micro\HiJackThis\HiJackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - F:\Program Files\AVG\AVG9\avgssie.dll
O4 - HKLM\..\Run: [StartCCC] "F:\Program Files\ATI Technologies\ATI.ACE\Core-Static\CLIStart.exe" MSRun
O4 - HKLM\..\Run: [RTHDCPL] RTHDCPL.EXE
O4 - HKLM\..\Run: [AVG9_TRAY] F:\PROGRA~1\AVG\AVG9\avgtray.exe
O4 - HKLM\..\RunOnce: [InstallShieldSetup] "F:\Program Files\InstallShield Installation Information\{D4C9692E-4EFA-4DA0-8B7F-9439466D9E31}\setup.exe" -rebootF:\PROGRA~1\INSTAL~1\{D4C96~1\reboot.ini -l0x0010
O4 - HKCU\..\Run: [CTFMON.EXE] F:\WINDOWS\system32\ctfmon.exe
O4 - HKCU\..\Run: [msnmsgr] "F:\Program Files\Windows Live\Messenger\msnmsgr.exe" /background
O4 - HKCU\..\Run: [DAEMON Tools Lite] "F:\Program Files\DAEMON Tools Lite\DTLite.exe" -autorun
O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] F:\WINDOWS\system32\CTFMON.EXE (User 'SERVIZIO LOCALE')
O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] F:\WINDOWS\system32\CTFMON.EXE (User 'SERVIZIO DI RETE')
O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] F:\WINDOWS\system32\CTFMON.EXE (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] F:\WINDOWS\system32\CTFMON.EXE (User 'Default user')
O4 - Startup: ONDA CONNECTION MANAGER.lnk = F:\Program Files\Onda Connection Manager\ONDA CONNECTION MANAGER.exe
O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - F:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - F:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - F:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - F:\Program Files\Messenger\msmsgs.exe
O17 - HKLM\System\CCS\Services\Tcpip\..\{77FB7620-F311-42C4-9763-9DF92A7FC997}: NameServer = 208.67.222.222,208.67.220.220
O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - F:\Program Files\AVG\AVG9\avgpp.dll
O20 - Winlogon Notify: avgrsstarter - avgrsstx.dll (file missing)
O22 - SharedTaskScheduler: Browseui preloader - {438755C2-A8BA-11D1-B96B-00A0C90312E1} - F:\WINDOWS\system32\browseui.dll
O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - F:\WINDOWS\system32\browseui.dll
O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - F:\WINDOWS\system32\Ati2evxx.exe
O23 - Service: ATI Smart - Unknown owner - F:\WINDOWS\system32\ati2sgag.exe
O23 - Service: Autorun CDROM Monitor - Unknown owner - F:\WINDOWS\system32\SupportAppXL\cdrom_mon.exe
O23 - Service: AVG Free E-mail Scanner (avg9emc) - AVG Technologies CZ, s.r.o. - F:\Program Files\AVG\AVG9\avgemc.exe
O23 - Service: AVG Free WatchDog (avg9wd) - AVG Technologies CZ, s.r.o. - F:\Program Files\AVG\AVG9\avgwdsvc.exe
O23 - Service: Intel(R) PROSet Monitoring Service - Intel Corporation - F:\WINDOWS\system32\IProsetMonitor.exe
O23 - Service: Intel(R) PROSet/Wireless Registry Service (RegSrvc) - Intel(R) Corporation - F:\Program Files\Common Files\Intel\WirelessCommon\RegSrvc.exe
O23 - Service: TeamViewer 5 (TeamViewer5) - TeamViewer GmbH - F:\Program Files\TeamViewer\Version5\TeamViewer_Service.exe

--
End of file - 5096 bytes



Grazie
fasenderos
Newbie
 
Post: 4
Iscritto il: 27/11/10 10:41

Sponsor
 

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi fasenderos » 27/11/10 11:05

Un altro programma che ho notato ora, non esser funzionante è Windows Live Messenger....mentre il Windows Messenger normale funziona...
grazie
fasenderos
Newbie
 
Post: 4
Iscritto il: 27/11/10 10:41

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi quizface » 27/11/10 13:14

ma in C: cos' hai?
hai provato a fare il contrario di quello che hai fatto la prima volta? modificare di nuovo la lettera del disco da C:\ a F:\?

Per maggior stabilita' del sistema, ti consiglio comunque un bel formattone.
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14166
Iscritto il: 03/10/04 00:36

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi fasenderos » 27/11/10 13:35

C:\ non esiste...diventa attivo solo quando inserisco una USB...
fare il contrario mi è impossibile, perchè ormai i nuovi file del registro di sistema sono quelli che ho trovato nella cartella Windows\repair
inoltre ho provato a vedere se esiste un punto di ripristino, ma non ce n'è nessuno prima del fattaccio...

Mi chiedevo esistono dei tool che verifichino se tutti i file di sistema e dll sono presenti, di modo che se ne manca qualcuno posso prenderli da un'altra installazione di windows che ho e inserirli...e anche se esiste un tool che corregga il registro di sistema, io ho provato con CCleaner ma non credo che faccia al caso mio
Grazie
fasenderos
Newbie
 
Post: 4
Iscritto il: 27/11/10 10:41

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi Magik » 27/11/10 14:16

segui il consiglio di quizface, formatta e è buona norma, installare il sistema operativo sempre su c:
Magik
Utente Senior
 
Post: 1759
Iscritto il: 08/12/04 13:45

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi fasenderos » 29/11/10 12:18

Magik ha scritto:segui il consiglio di quizface, formatta e è buona norma, installare il sistema operativo sempre su c:

Non sono sicuro che sia buona norma formattare...E' troppo facile così e oltretutto mi sembra assurdo che ogni volta che c'è un problema di windows, l'unica soluzione sia quella di formattare... come ho già detto io vengo da Linux, e per me la parola formattare non esiste...quindi, testardo come un mulo, mi sono messo a smanettare fino a che non sono riuscito a trovare la soluzione....ed ho risolto !!

Per i posteri spiego brevemente come ho fatto:

Allora il ripristino configurazione di sistema non trovava punti di ripristino anteriori al problema, però googlando un po' ho scoperto che i punti di ripristino vengono salvati in C:\System Volume Information.
Dentro ci sono una o più cartelle _restore{SEGUITE DA UNA SERIE DI NUMERI E LETTERE}, e dentro di queste altre cartelle RP1, RP2 ecc..con i vari punti di ripristino.. Dentro ogni cartella RPX c'è una cartella Snapshot, dove ci sono i vari file del registro di sistema.

_REGISTRY_USER_.DEFAULT
_REGISTRY_MACHINE_SECURITY
_REGISTRY_MACHINE_SOFTWARE
_REGISTRY_MACHINE_SYSTEM
_REGISTRY_MACHINE_SAM

Facendo click destro->proprietà su uno dei file, ho potuto vedere la data di creazione del file e così scegliere quelli con una data in cui ero sicuro che tutto fosse funzionante...trovati i file giusti, li ho rinominati(salvandone comunque prima un copia :) ) in:

default
security
software
system
sam

e poi li ho sostituiti con quelli che utilizza attualmente il registro di sistema, che si trovano in Windows\system32\config...ora il Registro di Sistema è ripristinato...

Una volta riparato il registro di sistema, avevo ancora dei problemi con alcuni programmi che non partivano, e immaginavo fosse un problema di DLL mancanti...allora ho trovato un programmino freeware col quale, aprendo una determinata applicazione, ti segnala quali librerie mancano (ed in effetti ne mancavano diverse)...una volta scoperto quali sono le librerie mancanti mi è bastato andare su www.dll-files.com (spero di non fare pubblicità a nessuno) e scaricarle...
Il programma in questione è:
Dependency Walker

Ora tutto funziona...
grazie
fasenderos
Newbie
 
Post: 4
Iscritto il: 27/11/10 10:41

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi Magik » 29/11/10 13:02

in questo caso, dato che si è modificato in modo radicale, ed è difficile riuscire a capire tutte le modifiche che sono state apportate, a quel punto, formatti, e stai tranquillo che in futuro nn si avranno problemi

dire che in questi casi la formattazione sia + per una tranquillità futura che per la velocità di risoluzione
Magik
Utente Senior
 
Post: 1759
Iscritto il: 08/12/04 13:45

Re: Diversi Problemi dopo aver tentato di modificare F:\ con

Postdi antoo69 » 29/11/10 17:41

Sei abituato a Linux e lo si capisce...rispetto a Windows è un sistema molto più autoconservativo, nel senso che è molto più difficile da manomettere, anche volendolo fare di proposito. Sta di fatto che sono sistemi differenti e perciò non si possono trattare allo stesso modo...questo lo devi prendere come un punto fermo. Riguardo alla risoluzione del tuo problema, direi che nessuno può aiutarti a far tornare il windows come prima, senza l'utilizzo di file immagine o backup, possiamo dire che hai distrutto le pareti portanti, perciò ,come già consigliato, fai prima a ricostruire che non a ristrutturare. Per il futuro il consiglio che posso darti è, fai tutti gli esperimenti che vuoi, ma prima fatti sempre un'immagine dell'hard disk per poter rimediare.
dai un pesce ad un uomo e lo sfamerai per un giorno.
insegna ad un uomo a pescare e lo sfamerai per tutta la vita.

Dell Alienware M17x
Avatar utente
antoo69
Moderatore
 
Post: 2106
Iscritto il: 28/04/09 16:40
Località: PARMA


Torna a Sistemi Operativi Windows


Topic correlati a "Diversi Problemi dopo aver tentato di modificare F:\ con C:\":

alcuni problemi...
Autore: gibo
Forum: Assistenza Hardware
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti