Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

problema driver

Risolvi qui i tuoi problemi legati a Windows '95, '98, ME, NT, 2000, XP, 2003, Vista...

Moderatori: -> EleKtrA <-, antoo69

problema driver

Postdi zzzhimo » 22/08/10 10:26

Ciao a tutti,
ho un problema. Ho installato sul pc con sistema operativo Vista il driver CP210x Usb to UART Bridge ma la versione che ho installato non andava bene per vista. Cosi dal sito ho scaricato una versione adatta per vista e ho elominato quella vecchia. Ora come provo a installare la nuova versione mi compare una finestra in cui si dice che è presente la vecchia versione di eliminare quella vecchia ma non c è più nulla o per lo meno anche da una ricerca manuale non trovo piu niente. Qualcuno sa aiutarmi?? grazieee
zzzhimo
Utente Junior
 
Post: 23
Iscritto il: 28/03/09 11:03

Sponsor
 

Re: problema driver

Postdi quizface » 22/08/10 11:27

dovresti spiegare cos' e', un cavo adattatore USB -> Seriale? puoi mettere il mettere il link dove hai preso entrambi i drivers?
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14162
Iscritto il: 03/10/04 00:36

Re: problema driver

Postdi zzzhimo » 23/08/10 09:29

si è un cavo usb/seriale.. devo programmare un robot che si collega al pc con usb; i driver vecchi li hi su cd, quelli nuovi li ho scaricati dal casa produttrice del robot che mi fornisce software per la programmazione del robot piu driver CP210x Usb to UART Bridge per Vista.http://www.robonova.de/store/support/index.php?_m=downloads&_a=viewdownload&downloaditemid=145&nav=0,6,16
zzzhimo
Utente Junior
 
Post: 23
Iscritto il: 28/03/09 11:03

Re: problema driver

Postdi zzzhimo » 23/08/10 09:39

stavo "frugando" nel pc e mi sono resa conto di questo:
andando su gestione dispositivi -> Controller USB->CP210x USB composite DEvice è segnalato con triangolo giallo e lo stato é: Impossibile caricare il driver di dispositivo per questo hardware. Il driver potrebbe essere danneggiato o mancante. (Codice 39)

Prima con la versione vecchia in gestione dispositivi mi compariva anche qualcosa sulla porta Com
zzzhimo
Utente Junior
 
Post: 23
Iscritto il: 28/03/09 11:03

Re: problema driver

Postdi quizface » 23/08/10 12:48

Allora, immagino che tu abbia scaricato e scompattato il file (di cui hai messo il link).
Ora nella cartella di scompattazione hai :
CP2101_V20 (cartella che ci interessa)
e quattro files che per installare il driver non ci interessano:
Autorun.inf
dotnetfx_e.exe
install.bat
MA-VIN_setup_english.exe
Vai sulla periferica col punto giallo, clicca destro e scegli aggiorna driver -> no non ora -> installa da un elenco....(per utenti esperti) -> non effettuare la ricerca... -> disco driver ...quindi devi indirizzare nella cartella CP2101_V20 nella dove hai i files slabbus.inf e slabw2k.inf
Comunque anche quel driver non e' specifico per vista (ma potrebbe andare bene slabw2k.inf che e' per windows 2000/XP)
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14162
Iscritto il: 03/10/04 00:36

Re: problema driver

Postdi quizface » 23/08/10 12:52

Questo dovrebbe essere quello giusto http://www.silabs.com/products/mcu/page ... ivers.aspx
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14162
Iscritto il: 03/10/04 00:36

Re: problema driver

Postdi zzzhimo » 23/08/10 14:31

Avevo gia provato a fare la procedura che mi hai consigliato ma niente purtroppo.
MI appare questa dicitura: il driver del dispositivo è stato rilevato ma si è verificato un problema durante l'installazione..
credo che il problema sia il codice 39
zzzhimo
Utente Junior
 
Post: 23
Iscritto il: 28/03/09 11:03

Re: problema driver

Postdi zzzhimo » 24/08/10 16:20

Allora frugando tra l'editor del registro ho trovato che in :
HKEY_LOCAL_MACHINE\Software\Silicon Laboratories\ ho la versione vecchia del driver e ho un sacco di voci che non so cosa siano... cosa significa? aiuto!!!
zzzhimo
Utente Junior
 
Post: 23
Iscritto il: 28/03/09 11:03

Re: problema driver

Postdi quizface » 24/08/10 19:00

Potresti provare a disinstallare il driver con USBDeview scollega il cavo e disinstalla il driver, ripulisci il registro con cccleaner o simili riavvii e provi a reinstallare il driver.
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14162
Iscritto il: 03/10/04 00:36

Re: problema driver

Postdi AndreaVale » 27/08/10 16:10

Ciao!
prova con un programma di diagnostica seria per i driver del sistema, tipo driver genius pro oppure driver robot, io uso il primo da tempo e dovrebbe individuarti subito qual'è il problema e proporti poi il corretto download.
AndreaVale
Utente Junior
 
Post: 15
Iscritto il: 06/05/09 16:10


Torna a Sistemi Operativi Windows


Topic correlati a "problema driver":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti