Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Partizioni perse

Risolvi qui i tuoi problemi legati a Windows '95, '98, ME, NT, 2000, XP, 2003, Vista...

Moderatori: -> EleKtrA <-, antoo69

Partizioni perse

Postdi Darver75 » 02/12/09 10:46

Salve a tutti. Spero riusciate ad aiutarmi a risolvere il problema che ora vi espongo.
Il mio pc desktop, mentre stavo trasferendo dei file su un dispositivo usb, è andato a nero con lo schermo anche se era rimasto acceso e la connessione ad internet continuava ad essere presente. Era già la terza volta che faceva questo difetto, solo che al riavvio il tutto si sistemava, eccetto per quest'ultima volta. Tutte le volte che è accaduto il problema stavo sempre trasferendo file su un dispositivo usb (penna o lettore mp3) mentre era in funzione eMule.
Veniamo al dunque. Al riavvio non mi partiva il sistema operativo, ho provato anche con F8 ma mi diceva Mdetect fallito. Alché ho montato la live di ubuntu ed ho notato che mi era rimasta una sola partizione attiva. Il mio pc ha due HD, quello con il SO ha due partizioni mentre l'altro ne ha una sola. In pratica ho perso le partizioni dove era presente il SO e quella dell'altro HD. Ho riavviato il tutto con il cd di installazione di windows e mi ha dato la conferma quando ho visto che mi considerava le due partizioni non formattate. Che abbiano perso i file system? Considerando che la partizione dove stava il SO la posso formattare tranquillamente e reinstallare windows xp, posso fare qualcosa per recuperare la partizione dell'altro HD senza formattare? Lì ci sono molti dati che vorrei recuperare.

Nota: in pratica stao utilizzando tutte e tre le partizioni quando è accaduto il fatto, poiché i file che stavo trasferendo sul dispositivo usb erano sulla partizione che si è salvata (fortunatamente), mentre eMule era attivo sulla partizione dell'altro HD. Penso che in tutto questo un pò di colpa ce l'abbia eMule e forse la scarsezza di prestazioni del mio vecchio pc.
AMD Athlon XP 1700+; 512Mb RAM; GeForce 2 MX/MX 400; O.S. WinXP
Darver75
Utente Junior
 
Post: 57
Iscritto il: 28/12/03 17:28

Sponsor
 

Re: Partizioni perse

Postdi antoo69 » 02/12/09 14:21

Prova con il comando chkdsk volume:/r. Controlla e ripara il file system. Per farlo sarebbe meglio montare l'hard disk su un altro pc o collegarlo mettendolo in un box per hard disk esterno. In alternativa puoi provare con i software di recupero dati che trovi nella sezione download.
dai un pesce ad un uomo e lo sfamerai per un giorno.
insegna ad un uomo a pescare e lo sfamerai per tutta la vita.

Dell Alienware M17x
Avatar utente
antoo69
Moderatore
 
Post: 2106
Iscritto il: 28/04/09 16:40
Località: PARMA

Re: Partizioni perse

Postdi Darver75 » 02/12/09 15:24

Grazie per la risposta. Solo una curiosità prima di procedere. Se monto l'HD come esterno su un notebook, poi il SO riesce a leggermi le partizioni anche non formattate? Perché se non le vede non potrei utilizzare il comando su di esse (Dico questo perché la live di Ubuntu non mi ha letto le due partizioni perse e non vorrei che accadesse lo stesso come HD esterno), che dovrei lanciare da terminale se non sbaglio.
La mia procedura alternativa, che a questo punto spero di evitare utilizzando il comando che mi hai consigliato, prevedeva la formattazione della partizione del SO e la sua reinstallazione, e poi l'utilizzo di programmi quali acronis (versione trial, sperando che mi recuperi la tabella del file system) o testdisk che posso provare a lanciare anche da Ubuntu, ammesso che riesca a capire bene il suo utilizzo da riga di comando (purtroppo windows mi ha abituato troppo male...mi cospargo il capo di cenere).
AMD Athlon XP 1700+; 512Mb RAM; GeForce 2 MX/MX 400; O.S. WinXP
Darver75
Utente Junior
 
Post: 57
Iscritto il: 28/12/03 17:28

Re: Partizioni perse

Postdi antoo69 » 02/12/09 15:40

Il comando è da eseguire su un pc sano con installato windows, START<ESEGUI e digita quanto scritto prima. Il dubbio che muovi è fondato, potrebbe non essere possibile eseguire questo comando, ma tentare non nuoce. Montandolo così puoi anche provare il con la gestione disco di xp per vedere cosa esso legge del tuo povero disco.. per le altre utility che hai elencato secondo me si gestiscono meglio montandolo come hard disk esterno.
dai un pesce ad un uomo e lo sfamerai per un giorno.
insegna ad un uomo a pescare e lo sfamerai per tutta la vita.

Dell Alienware M17x
Avatar utente
antoo69
Moderatore
 
Post: 2106
Iscritto il: 28/04/09 16:40
Località: PARMA

Re: Partizioni perse

Postdi Darver75 » 02/12/09 17:04

Nell'attesa di andare a recuperare un box per HD esterno mi sono ricordato di avere un floppy di avvio del vecchio win98. L'ho fatto partire e mi ha caricato un pò di dos. La cosa strana è che in quel caso riesco a leggere tutte le partizioni e a vederne il contenuto. Ho lanciato allora il comando che mi hai suggerito, ma il dos mi ha imposto di usare lo scandisk. Ho eseguito il comando su c: e mi ha corretto tutta una serie di errori. Alla fine però mi ha detto che non è stato possibile correggerli tutti. Cmq sperando che avesse risolto qualcosa ho provato a riavviare ma non è cambiato nulla. Continua a non vedermi la partizione sulla quale avevo agito con scandisk.
Spero che le cose vadano meglio con il collegamento all'altro pc, ma credo che dovrò utilizzare qualche tool apposito, forse.
AMD Athlon XP 1700+; 512Mb RAM; GeForce 2 MX/MX 400; O.S. WinXP
Darver75
Utente Junior
 
Post: 57
Iscritto il: 28/12/03 17:28

Re: Partizioni perse

Postdi antoo69 » 02/12/09 17:15

Se con il dos funziona non puoi fare un bel xcopy della partizione con i dati sul secondo hard disk? Poi controlli se ha copiato tutto quello che ti interessa, e se è andato tutto bene formatti il disco 1 e tantio saluti alle partizioni che non si vedono.
dai un pesce ad un uomo e lo sfamerai per un giorno.
insegna ad un uomo a pescare e lo sfamerai per tutta la vita.

Dell Alienware M17x
Avatar utente
antoo69
Moderatore
 
Post: 2106
Iscritto il: 28/04/09 16:40
Località: PARMA

Re: Partizioni perse

Postdi Darver75 » 02/12/09 18:05

Non potevo utilizzare l'xcopy perché le altre partizioni sono quasi piene e di conseguenza non potevo copiare tutti i file da una partizione all'altra. Cmq ho risolto il problema in un altro modo. Ora mi vede tutte le partizioni ma il sistema al riavvio mi da la schermata blu della morte con tutta una serie di errori. Essendo la mia scheda video alla frutta, so che è colpa sua, probabilmente il crash deve aver incasinato il sistema e dovrò per forza di cose reinstallare il SO. Dopo questa ennesima avventura mi sono convinto ad aggiornare il pc ;)

Ho scaricato dalla vostra sezione download l'Ultimate Boot CD 4.1.1.
Ho fatto il boot da Cd ed ho caricato il TestDisk con il quale sono riuscito a ripristinare le partizioni.
Riporto la procedura che ho seguito, in modo tale che possa essere utile per chiunque altro avrà lo stesso problema.
Il programma all'avvio individua gli HD presenti.
Ho scelto quello che mi interessava, dopodiché vi chiede la partizione (Nel mio caso ho scelto Intel)
A quel punto ho scelto l'opzione “Analyse” per analizzare la struttura delle partizioni presenti e perse.
Mi ha dato come output → test_FAT : Boot sector doesn't have the endmark 0xAA55
Ho scelto l'opzione “proceed” ed è partita l'”analyse cylinder”
Scegliete la partizione e premete semplicemente Invio per continuare.
Scegliete l'opzione “Search” che farà un ulteriore analisi approfondita e aspettate il risultato.
La ricerca vi individua la partizione con il problema indicandola con l'asterisco. Selezionatela e premete Invio. Poi scegliete l'opzione “Write” e confermate.
Essendoci un problema sul boot il programma dice che il primo settore ed il secondo non sono identici. A questo punto scegliete l'opzione [Backup BS] che ripristinerà una copia precedente del boot. Confermate e avrete il messaggio che ora i settori sono identici.
Terminata la procedura, quittare il programma e riavviare il tutto.

Grazie Antoo69 per avermi ascoltato e indirizzato verso la soluzione.
AMD Athlon XP 1700+; 512Mb RAM; GeForce 2 MX/MX 400; O.S. WinXP
Darver75
Utente Junior
 
Post: 57
Iscritto il: 28/12/03 17:28

Re: Partizioni perse

Postdi antoo69 » 02/12/09 18:11

Complimenti a te che hai risolto, io ho solo buttato lì qualche idea...e grazie per aver scritto con dovizia di particolari la procedura che ti ha consentito di risolvere il problema. ;)
dai un pesce ad un uomo e lo sfamerai per un giorno.
insegna ad un uomo a pescare e lo sfamerai per tutta la vita.

Dell Alienware M17x
Avatar utente
antoo69
Moderatore
 
Post: 2106
Iscritto il: 28/04/09 16:40
Località: PARMA


Torna a Sistemi Operativi Windows


Topic correlati a "Partizioni perse":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti