Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Niente video in Subtitle Workshop

Problemi di Codec - AC3, MPEG, DivX, Xvid...? Vuoi aiuto con la tua musica? Non sai come masterizzare i tuoi mp3? In questo forum tutte le risposte alle tue domande legali!

Moderatori: axelrox, m.paolo

Niente video in Subtitle Workshop

Postdi giko » 09/07/07 09:51

Ciao a tutti.
Ho cominciato ad approcciarmi a Subtitle Workshop per creare dei sottotitoli a video. Purtroppo pero' alcuni video, nella finestra in alto, non si vedono, mentre si sente l'audio! Non so se ci sono settaggi da fare, intanto dal menu Filmato - Informazioni, riporto i dati-tipo di un video che non si vede:

Nome del file: C: ....... .avi
Dimensione: 10.81 MB
FPS: 29.97
Durata: 00:01.49.109
Frame totali: 3270
Risoluzione: 0x0
FourCC: divx

Grazie a tutti per l'attenzione e per eventuali consigli.
giko
Newbie
 
Post: 9
Iscritto il: 04/07/07 10:29

Sponsor
 

Postdi Pao1o » 09/07/07 11:46

Quando capita questo problema in subwork

1) o è perchè il tuo computer sta usando troppe risorse per altre operazioni (non so che cpu hai, ma prova a riavviare facendo lavorare solo subwork).

2) oppure è perchè non hai tutti i codec necessari (subwork non ha codec interni e si appoggia ai codec gia installati). Carica il film in gspot e controlla di avere i codec necessari.

3) può darsi che il filmato sia leggermente corrotto e perciò non pienamente accettato da subwork. In questo caso prova a caricarlo in virtual dub \ voce video -----> direct stream copy \ voce file -----> save as
Se ancora non bastasse ripassalo in divfix add files \ rebuild index
Immagine
Avatar utente
Pao1o
Utente Senior
 
Post: 1375
Iscritto il: 23/10/05 12:58
Località: non scrivo più su questo forum per divergenze

Postdi giko » 10/07/07 10:11

Grazie per avermi risposto. Allora, vado con ordine
-non credo sia per l'ipotesi 1 (ho un p4, ed ho provato facendo lavorare solo subwork).
-i codec, questi sconosciuti: dove si controlla se i codec sono gia' installati?
-appena aperto con virtual dub mi da questo avviso:
"AVI: Variable bitrate (VBR) audio detected. VBR audio in AVI is non-standard and you may encounter sync errors up to 1794ms when attempting to extract WAV files or processing the audio in Direct Stream Copy mode. Full processing mode is reccomended to decompress or recompress the audio. (bitrate: 127.3+-35.2 kbps)". Quindi l'ho passato in full processing mode ed ora finalmente in subwork si vede il video pero' audio-video non sono in sincrono ed il nuovo file da 17 Mb e' diventato quasi 1.5 Gb.
Ti rinrazio in anticipo se avrai ancora la pazienza di rispondermi
Ciao
giko
Newbie
 
Post: 9
Iscritto il: 04/07/07 10:29

Postdi Pao1o » 10/07/07 12:08

Allora, vado anche io con ordine.

1) non è un problema di cpu

2) il discorso sui codec è un po' complicato. Fai una ricerca su questo forum "codec" e leggiti un po' di topics (ne abbiamo parlato molto spesso).
Per controllare se hai i codec, scaricati gspot
http://www.pc-facile.com/download/codec/gspot/135.htm
caricaci il film e vedi cosa ti dice.
Guida sui codec

3) l'audio in vbr è un problema perchè spesso e volentieri ti va fuori sincrono.
Soluzioni: demuxarlo (es. con Xilisoft Audio Converter (in demo)), ci carichi l'avi, imposti decoder lame, da settings \ vbr disabled e imposti i kbs che vuoi (128 o 192 di solito).
Dai un'occhiata anche qui
http://www.pc-facile.com/forum/viewtopi ... hlight=vbr
Ti avviso che l'audio in vbr è quasi impossibile da risincronizzare

3 bis) il full processing mode ti porta via un sacco di tempo (fa la ricodifica) nel tuo caso (problema di audio) è inutile.
Il file ti viene fuori di quelle dimensioni, perchè una volta scelto il full process, devi anche scegliere un codec di compressione [virtualdub \ video \ compression scegli divx o xvid (meglio)].
Qui torniamo al problema dei codec, perchè senza codec, non riesci ad impostare la compressione in virtual dub.


Facci sapere se hai altri problemi che li affrontiamo.

Ciao.
Immagine
Avatar utente
Pao1o
Utente Senior
 
Post: 1375
Iscritto il: 23/10/05 12:58
Località: non scrivo più su questo forum per divergenze

Postdi Pao1o » 10/07/07 14:04

Dimenticavo: dopo che hai demuxato (separato) l'audio e trasformato da vbr (variabile) in cbr,
lo devi remuxare (riunire) al film
Carichi il film sempre in virtual dub (a secondo delle versioni) voce audio (o stream list)
clicchi sulla vecchia traccia \ disable, poi add e ci aggiungi la nuova che hai sistemato.
Avatar utente
Pao1o
Utente Senior
 
Post: 1375
Iscritto il: 23/10/05 12:58
Località: non scrivo più su questo forum per divergenze

Postdi Pao1o » 10/07/07 14:14

Dimentico ancora: tutte queste operazioni di audio, le fai dallo voce video \ direct stream copy.

Così impieghi pochi minuti per operazione
Avatar utente
Pao1o
Utente Senior
 
Post: 1375
Iscritto il: 23/10/05 12:58
Località: non scrivo più su questo forum per divergenze

Postdi giko » 10/07/07 16:44

Grazie davvero Pao1o,
studiero' un po, provero' e ti faro' sapere,
a presto.
giko
Newbie
 
Post: 9
Iscritto il: 04/07/07 10:29


Torna a Audio/Video e masterizzazione


Topic correlati a "Niente video in Subtitle Workshop":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti