Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

problemi visualizzazione sito con explorer 7

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

problemi visualizzazione sito con explorer 7

Postdi alianna81 » 30/09/08 14:43

Salve a tutti, ho creato un piccolo sito per mio marito fotoamatore: http://www.dagofotografo.com (sono alle primissime armi con il linguaggio html) ed ho utilizzato jalbum per la visualizzazione delle foto. Visto che il programma genera in automatico le pagine html per ogni immagine, ho portato i file su locale ed ho aggiunto una pagina di index che raccoglie tutti gli album e per ogni file html l'intestazione del sito e il menù, trasferendo poi i file corretti con FTP. Con Modzilla e Safari il sito si vede bene, quando però lo apro con explorer 7 e vado alla pagina della gallery fotografica, appare la pagina di index corretta e subito dopo una finestra che mi dice che è impossibile visualizzare la pagina web, cliccando su ok mi sparisce la pagina. Con explorer 8 beta invece il sito funziona bene. Potrei avere fatto degli errori quando ho corretto gli html delle immagini? Qualcosa che entra in conflitto con explorer 7? Ma che cosa? Boh! A qualcuno è capitata la stessa cosa? Grazie a tutti in anticipo :D
alianna81
Newbie
 
Post: 7
Iscritto il: 03/02/05 14:10

Sponsor
 

Re: problemi visualizzazione sito con explorer 7

Postdi archimede » 30/09/08 17:07

Non ho idea di quale possa essere il problema ma fossi in te inizierei a rivedere accuratamente il codice delle tue pagine. Le prime due cose che sono saltate all'occhio sono </div align> invece di </div> e l'apertura del tag body in almeno due posti. La compatibilità dell'HTML su browser diversi non è una passeggiata, ma con questi presupposti diventa quasi una missione impossibile.

HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: problemi visualizzazione sito con explorer 7

Postdi alianna81 » 30/09/08 19:10

Grazie Alessandro, presumevo che parte dei problemi fosse riconducibile ad errori di compilazione (quelli che hai citato tu sono davvero grossolani :oops: ). Rivedrò tutti i codici e poi...che Dio me la mandi buona! :)
Anna
alianna81
Newbie
 
Post: 7
Iscritto il: 03/02/05 14:10

Re: problemi visualizzazione sito con explorer 7

Postdi enore.savoia » 04/10/08 05:53

Ciao Arianna e Alessandro

Ho dato una occhiata veloce .. e testato le pagine tramite http://validator.w3.org/

con IE7 Firefox 3.0.3 e Google Chrome mi rispondono perfettamente !

Non sò se nel frattempo Arianna abbia corretto parti del codice .. ma gli errori sono veramente pochi !
Per essere alle prime armi ... i miei complimenti ;)

Arianna ti suggerisco il validatore w3c per avere una visione generale degli errori presenti nelle pagine ... cosi puoi seguire anche i suggerimenti (e relativa linea) che ti verranno proposti per attuare le correzioni !

Spuntando la casella view source .. potrai inoltre visionare la pagina completa (linee) a riferimento per dove intervenire

buona cosa da fare per velocizzare la lavorazione è inviare (upload) i file .html per una verifica in locale ... una volta validati li porterai sul tuo server !

saluti
web project manager - consultant freelance
Avatar utente
enore.savoia
Utente Junior
 
Post: 13
Iscritto il: 11/09/08 14:53
Località: Montecatini Terme (Pistoia)

Re: problemi visualizzazione sito con explorer 7

Postdi alianna81 » 06/10/08 12:21

@enore.savoia, grazie per il suggerimento che metterò subito in pratica. Non conoscevo il programma e lo trovo prezioso per il controllo dei codici!
Un saluto,
Anna
alianna81
Newbie
 
Post: 7
Iscritto il: 03/02/05 14:10


Torna a Programmazione


Topic correlati a "problemi visualizzazione sito con explorer 7":

foto su sito web
Autore: sic58
Forum: Sicurezza e Privacy
Risposte: 0

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti