Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Lettura di alcuni attributi XML

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

Lettura di alcuni attributi XML

Postdi Atroban » 11/11/05 12:13

Ciao a tutti, ho un problema con la lettura di un files XML, sono abbastanza ignorante in materia quindi potrei anche essermi perso in un bicchier d'acqua... il mio problema nasce dalla necessità di leggere un file di questo tipo:

<persona anni="5">
<uomo nome="Marco"/>
</persona>

il fatto è che utilizzando la funzione GetAttribute di C# succede questo

GetAttribute("anni") mi restituisce (correttamente) il valore 5 per il primo nodo e nessuno per il secondo...

mentre

GetAttribute("nome") non restituisce mai nulla... ne' per il primo ne' per il secondo...

però se cambio la scrittura del file XML in

<persona anni="5">
<uomo nome="Marco">
<uomo/>
</persona>

GetAttribute("nome")stavolta restituisce (correttamente) Marco... sbaglio qualcosa di teorico con l'XML o è un problema di c#?

grazie
------carpe diem------
Atroban
Utente Senior
 
Post: 210
Iscritto il: 13/01/05 23:34
Località: Provincia di Brescia

Sponsor
 

Postdi zello » 11/11/05 22:36

Non conosco il C#, ma in C++ le classi del .net framework mi sembrano funzionare:
Codice: Seleziona tutto
#using <mscorlib.dll>
#using <System.Xml.dll>

using namespace System;
using namespace System::Xml;

int main()
{
   XmlDocument* doc=new XmlDocument();
   doc->LoadXml("<persona anni=\"5\"><uomo nome=\"Marco\"/></persona>");
   XmlElement* elm=doc->DocumentElement;
   Console::WriteLine(elm->GetAttribute("anni"));
   elm=dynamic_cast<XmlElement*>(elm->FirstChild);
   Console::WriteLine(elm->GetAttribute("nome"));
   return 0;
}

Output:
Codice: Seleziona tutto
5
Marco
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44

Postdi Atroban » 12/11/05 01:14

Grazie mille ho ricontrollato tutto e mi son accorto... che non era il getAttribute il problema ma il controllo su un ciclo... utilizzavo una funzione che mi ritornava false se il nodo era vuoto... ed in effetti questi son considerati nodi vuoti... mi pare fosse IsEndNode o IsEmptyNode.... grazie mille!!!

:lol:
------carpe diem------
Atroban
Utente Senior
 
Post: 210
Iscritto il: 13/01/05 23:34
Località: Provincia di Brescia


Torna a Programmazione


Topic correlati a "Lettura di alcuni attributi XML":

alcuni problemi...
Autore: gibo
Forum: Assistenza Hardware
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti