Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Come si fa l'OR dei SE in excel?

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

Come si fa l'OR dei SE in excel?

Postdi cassioli » 08/09/05 14:50

come implemento una cosa tipo questa?

Codice: Seleziona tutto
( se(a1=b1;"yes","no) ) or ( se(a1=c1;"yes";"no") )
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Sponsor
 

Postdi Dylan666 » 08/09/05 15:06

sposto
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Postdi Garde » 08/09/05 15:18

Non sono sicuro di aver capito bene l'esempio, ma puoi nidificare fino a sette funzioni SE.
=SE(A1=2;"CIAO";(SE(A1=3;"CIAO";"Arrivederci")))
In questo caso se nella cella A1 c'è il numero 2 o 3 scrive ciao altrimenti arrivederci.
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi cassioli » 08/09/05 17:39

Garde ha scritto:Non sono sicuro di aver capito bene l'esempio, ma puoi nidificare fino a sette funzioni SE.
=SE(A1=2;"CIAO";(SE(A1=3;"CIAO";"Arrivederci")))
In questo caso se nella cella A1 c'è il numero 2 o 3 scrive ciao altrimenti arrivederci.

Gia', si potrebbe.
Eppure mi pareva che si potessero usare anche AND e OR, senza fare cose arzigogolate... boh?
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Postdi Garde » 08/09/05 18:31

Cosi?
=SE((O(A1=1;B1=2));"vero";"Falso")

Questa se almeno una delle due celle rispetta la condizione
a1 deve essere uguale a 1 e b1 deve essere uguale a 2 scrive vero o falso nella cella.
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi cassioli » 08/09/05 18:34

Garde ha scritto:Cosi?
=SE((O(A1=1;B1=2));"vero";"Falso")

Questa se almeno una delle due celle rispetta la condizione
a1 deve essere uguale a 1 e b1 deve essere uguale a 2 scrive vero o falso nella cella.

Perfetto.
Grazie.
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Postdi Garde » 08/09/05 18:35

Rileggendo mi sono accorto che mi sono espresso come uno sherpa.
Se il valore della cella A1 e 1 o il valore nella cella B1 e 2 la funzione SE scrive "Vero" (o "pippo", o "ciao" o quelloche vuoi) nella sua cella .
se nessuna delle due condizioni si verifica scrive "falso" (o "topolino", o "mietitrebbia" ecc)
ciao
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi cassioli » 08/09/05 18:38

Garde ha scritto:Rileggendo mi sono accorto che mi sono espresso come uno sherpa.
Se il valore della cella A1 e 1 o il valore nella cella B1 e 2 la funzione SE scrive "Vero" (o "pippo", o "ciao" o quelloche vuoi) nella sua cella .
se nessuna delle due condizioni si verifica scrive "falso" (o "topolino", o "mietitrebbia" ecc)
ciao

Si, vabbe', tanto la spiegazione manco l'ho letta, ho letto la formula! :lol: ;)
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Postdi klizya » 08/09/05 18:48

dovrebbe essere così se non ricordo male:
SE(A1=B1;VERO;FALSO)*O(A1=C1)
klizya
Utente Senior
 
Post: 901
Iscritto il: 09/06/05 12:03
Località: Grosseto


Torna a Programmazione


Topic correlati a "Come si fa l'OR dei SE in excel?":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron