Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Problemi con IIS 5.1

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

Problemi con IIS 5.1

Postdi dinotz » 09/07/03 08:55

Ho realizzato un sito con degli script in ASP che sul server funziona correttamente. Vorrei testarlo in locale e per questo ho istallato IIS 5.1 sul mio WIN XP. Ho attivato una directory virtuale collegata alla cartella contenente il sito web.
Fin qui tutto bene, infatti riesco a testare le pagine ASP, tranne per uno script che dovrebbe leggere un file di testo. Lo script è sicuramente corretto perchè sul server funziona. Vi riporto comunque lo script:

<%
var FileObject, InStream;
FileObject = Server.CreateObject("Scripting.FileSystemObject");

//LEGGO IL FILE
InStream = FileObject.OpenTextFile(Server.MapPath("prova.txt"), 1,false, false);

%>

In locale la pagina non si carica mai, bloccandosi alla riga in cui viene creato l'oggetto Scripting.FileSystemObject senza dare errore!

Come posso risolvere questo problema?

Grazie per l'aiuto.
dinotz
Utente Junior
 
Post: 42
Iscritto il: 08/03/03 16:17
Località: Manfredonia

Sponsor
 

Postdi francy » 09/07/03 09:03

Ma hai abilitato l'esecuzione degli script sulla directory virtuale?
francy
Utente Senior
 
Post: 464
Iscritto il: 03/12/02 11:11
Località: Udine

Postdi dinotz » 09/07/03 09:16

Nella directory virtuale hanno la spunta le seguenti voci:
1. Accesso origine script
2. Lettura
3. Scrittura
4. Registrazione visite
5. Indicizza questa risorsa

Inoltre:
Autorizzazioni di esecuzione: solo script
Protezione applicazione: Media(pool)
dinotz
Utente Junior
 
Post: 42
Iscritto il: 08/03/03 16:17
Località: Manfredonia

Postdi francy » 09/07/03 11:20

dinotz ha scritto:Autorizzazioni di esecuzione: solo script

Prova con Script ed eseguibili...
francy
Utente Senior
 
Post: 464
Iscritto il: 03/12/02 11:11
Località: Udine

Postdi verbal666 » 09/07/03 16:31

se hai installato norton antivirus c'è lo script-blocking che interferisce con gli script asp... devi levarlo e riavviare...
!sto con Windows, ma amo Linux! ;)
Immagine
http://www.verbal.it
verbal666
Utente Senior
 
Post: 693
Iscritto il: 27/12/02 12:13

Postdi dinotz » 10/07/03 11:07

Era proprio lo script-blocking di Norton Antivirus a bloccare gli script ASP.

Grazie.
dinotz
Utente Junior
 
Post: 42
Iscritto il: 08/03/03 16:17
Località: Manfredonia


Torna a Software Windows


Topic correlati a "Problemi con IIS 5.1":

alcuni problemi...
Autore: gibo
Forum: Assistenza Hardware
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti