Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL: Tempo di Chiusura dei Files eccessivamente lungo

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

EXCEL: Tempo di Chiusura dei Files eccessivamente lungo

Postdi gianluigi » 07/04/02 13:04

Il mio PC ha:
CPU : Intel Pentium III – 600 Mhz
Hard Disk : 13 GB
RAM : 128 MB
Uso Windows98 e Excel 97 (da Office97 Professional Edition)

Da oltre un anno, tutto ha sempre funzionato correttamente.
Da alcune settimane sono aumentati incredibilmente i tempi
di chiusura dei Fogli di Lavoro in Excel.

A titolo di esempio, per chiudere un foglio di lavoro
contenente anche solo pochissimi dati occorrono 20-25 secondi.
Un foglio di lavoro da 70 KB richiede anche 50 secondi.
Questo inconveniente e’ per me particolarmente gravoso,
perche’ uso molto spesso Excel. A volte ho fino a 16 Fogli di
lavoro aperti; per la loro chiusura sono stati necessari
anche 12 minuti primi !!!

Potete per favore spiegarmi quale puo’ essere stata la causa e
Quali provvedimenti prendere per ritornare alla normalita’?
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Sponsor
 

Postdi RayZ » 07/04/02 14:38

se on hai installato nulla che possa giustificare la diversita' tra ora e prima, tipo add-on, macro, risolutori vari per Excel, potresti provare con un'ottimizzazione completa del sistema, defrag incluso.

se il disco e' pieno e hai poca memoria, potrebbe anche trattarsi di una difficolta' di Win stesso, che non riesce piu' a gestire il suo file di swap. in questo caso dovresti liberare un po' di spazio su disco, iniziando magari dai file temporanei.

se hai molti fogli correlati, con formule che fanno riferimento a fogli su altri file, semplifica il tuo sistema: Excel e' un buon database, ma solo finche' non fai sul serio.
(-: ray :-)
RayZ
Utente Senior
 
Post: 107
Iscritto il: 26/08/01 01:00
Località: Milano

Postdi gianluigi » 08/04/02 07:54

Anzitutto grazie grazie per la sollecita e dettagliata risposta.

In merito agli argomenti esposti, preciso:
1 - non ho installato nulla che possa giustificare la diversità tra ora e prima.
2 - come consigliato, questa notte ho eseguito lo scan-disk e la deframmentazione,
ma non ci sono stati miglioramenti. Il tempo di chiusura e' sempre estremamente
lungo.
3 - nell'hard disk ho 9 GB liberi
4 - a volte devo aprire fino a 16 fogli contemporaneamente. Essi non sono pero'
correlati, ma sono singolarmente indipendenti.

Tutto cio' premesso, che cosa mi consigli di fare ?
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi RayZ » 08/04/02 08:28

ci penso. e nel frattempo magari qualcuno sapra' aggiungere qualche suggerimento interessante.

tu pero' fai mente locale su quello che puoi aver cambiato, tra *prima* e *dopo*, perche' qualcosa DEVI aver fatto: i pc e win non sono imprevedibili fino a questo punto.

* quali applicazioni ha installato recentemente? pensa anche a quelle che ritieni piu' innoque...
* hai controllato cosa gira sul pc (task manager) quando ha completato il boot e quando hai Excel aperto?
* avrai certamente provato a fare il tuo lavoro avviando solo Excel...
* hai fatto qualche aggiornamento del sistema o di office?
(-: ray :-)
RayZ
Utente Senior
 
Post: 107
Iscritto il: 26/08/01 01:00
Località: Milano

Postdi gianluigi » 09/04/02 09:27

Rispondo al tuo messaggio di ieri.
1 - recentemente ho installato l'Antivirus EZ Armor , che e' composto da tre spplicazioni:
# eTrust EZ Antivirus
# eTrust EZ Firewall
# eTrust EZ DeskShield
Inizialmente le avevo inserite tutte tre nell'Esecuzione Automatica all'avvio del computer.
Ho fatto ora la prova disinserendo via via queste tre applicazioni.
Ho rilevato che se non apro la terza (DeskShield), il tempo di chiusura dei Fogli di Lavoro
di Excel scende a OTTO secondi. E' ancora un tempo elevato; ma molto meno dei tempi
misurati prima.
Poiche' DeskShield serve per verificare la posta in arrivo, la apro prima di collegarmi alla
mia casella di posta elettronica e la chiudo a fine collegamento. La cosa non mi disturba
percheìfacilmente realizzabile (apertura con un'icona sul desktop; chiusura con l'icona
che appare nel TRAY).

2 - Ho fatto la prova seguente:
# ho eliminato le icone che comparivano nel TRAY in fondo a destra; ho lasciato solo
quella del volume del suono.
Con CTRL+ALT+CANC ho visto che è aperta solo l'applicazione "Explorer"
# ho aperto Excel
Con CTRL+ALT+CANC ho visto che sono aperte le applicazioni "Explorer"e
"Microsoft Excel"
# ho digitato poche cose nel foglio di lavoro di Excel, l'ho salvato e poi chiuso.
Il tempo di chiusura è stato ancora di OTTO secondi.

3 - Non ho fatto alcun aggiornamento del sistema o di office.

Ti ringrazio ancora moltissimo per i consigli, che mi hanno consentito di migliorare molto
molto la situazione.
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi RayZ » 09/04/02 14:02

ciao gianluigi, in questo momento rispondo a ruota libera, poi vado a verificare, ma non ora perche' non posso (magari questa sera).

Dopo aver acceso il computer, vai su Risorse del computer e controlla le Prestazioni, per vedere quanta memoria ti mette a disposizione il sistema.

Dopo aver controllato la posta fai lostesso, anche se hai chiuso tutte le applicazioni utilizzate: win non rilascia mai completamente la memoria utilizzata dalle applicazioni.

se il tuo sistema ha poca ram (quanta ne ha?), e' possibile che excel debba poi appoggiarsi troppo alla memoria virtuale, in pratica uno spazio su disco che win gestisce per compensare la carenza di memoria ram. quella virtuale e', pero', decisamente piu' lenta di quella fisica: la trasmissione avviene alla stessa velocita' dello scambio dei dati con il disco, appunto.

trovando un buon equilibrio tra ram e memoria virtuale potresti migliorare ulteriormente la situazione. aumentando la ram potresti migliorare ulteriormente la situazione (ma attenzione a non superare i 512 mb, altrimenti la peggiori). con dischi piu' veloci potresti migliorare ulteriormente la situazione.

hai notato i condizionali? i pc sono *belli* perche' sono cosi' imprevedibili...
(-: ray :-)
RayZ
Utente Senior
 
Post: 107
Iscritto il: 26/08/01 01:00
Località: Milano

Postdi gianluigi » 09/04/02 17:26

Ciao RayZ, ancora ringraziandoTi per la velocita' nella risposta,
eccoti i risultati delle prove fatte.

Premetto che ho una RAM di 128 MB e che la memoria Virtuale
è settata per gestione automatica da parte di Windows.

Riporto i valori delle risorse di sistema disponibili indicati nella scheda
Prestazioni e la dimensione del file swap Win386.swp

# all'avviamento del PC, prima di aprire Excel : 86 % 4 MB
# dopo l'apertura di Excel : 80 % 0
# dopo aver creato e salvato un file in Excel
di soli 18 KB : 80 % 4 MB
# dopo aver aperto un file di Excel da 72 KB : 78 % 4 MB
# ........................ due : 78 % 0
# ........................ tre : 78 % 0
# .......................quattro : 78 % 0
# .......................cinque : 78 % 0
# .......................dieci : 78 % 4 MB
# ........................sedici : 78 % 4 MB

Dopo la chiusura dei 17 file di Excel e di Excel 80 % 4 MB

Successivamente, dopo aver scaricato la posta (31 messaggi
per un totale di circa 900 KB) i valori sono stati 72 % 24 MB
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi RayZ » 10/04/02 07:47

ciao gianluigi, devo ammettere di essere in difficolta'.

l'utilizzo della memoria rientra nella norma, quindi non dobbiamo cercare li' la causa del problema.

la dilatazione dei tempi di gestione dei file si e' verificata dopo che hai installato l'antivirus (se ho capito bene), quindi ti direi di disinstallare l'antivirus e verificare come funziona Excel: se riprende ad andare normalmente e decidi di reinstallare comunque l'antivirus, almeno saprai perche' e' piu' lento.

qualche altro controllo con Excel, anche se credo hai gia' risposto in questo lungo thread: i componenti aggiuntivi e le macro in esecuzione. mah

scusa ma non mi viene in mente altro. se qualcuno sta seguendo questa discussione, forse avra' qualcosa da aggiungere.

considera infine che c'e' sempre il consiglio da *ultima spiaggia*: quando non si sa piu' che fare... una bella riformattazione e via di nuovo! qualcuno la considera una sconfitta (io, per esempio), ma in fondo e' come dare una bella ripulita in casa.

alla prossima
(-: ray :-)
RayZ
Utente Senior
 
Post: 107
Iscritto il: 26/08/01 01:00
Località: Milano

Postdi JClark » 10/04/02 09:40

Ciao e scusate l'assenza,

quello che segnali è un bug che MS ha patchato con la SP1 o 2 per Office97.

Dopo un po' che usi il pacco (... volevo dire pacchetto) in questione, questi ha dei problemi a chidere i suoi stessi file ... :eeh:

Per quello che ne so la parte HW una volta tanto non centra nulla
Il brutto tempo non esiste ... il brutto tempo è quello che passo senza andare in moto !

Bye Frank
:-)
JClark
Utente Senior
 
Post: 416
Iscritto il: 24/09/01 01:00
Località: Voghera

Postdi RayZ » 10/04/02 09:53

Grazie JClark, speravo proprio in un altro intervento. Se la cosa si risolve come dici, dovro' anche cospargermi il capo di cenere per non aver verificato tra le patch per Office 97.

Solo, mi lascia un po' perplesso il fatto che gianluigi abbia ottenuto dei miglioramenti rispetto alla situazione iniziale descritta nel thread. puo' darsi che ci sia una sovrapposizione di problemi.

aspettiamo dunque di sapere come va a finire.
(-: ray :-)
RayZ
Utente Senior
 
Post: 107
Iscritto il: 26/08/01 01:00
Località: Milano

Postdi gianluigi » 10/04/02 22:16

Ciao RayZ
Nuovamente grazie per le sollecite risposte e per i validi consigli.
In merito ai tuoi due messaggi di questa mattina, non appena possibile
proverò a disinstallare Antivirus.
Naturalmente ti comunicherò i risultati.
Cordialità.
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi gianluigi » 10/04/02 22:17

[Ciao JClark
Grazie anzitutto per essere intervenuto in mio aiuto.
Ti vedo molto deciso nell’attribuire la colpa dei miei
problemi ad un BUG di MS.
Potresti indicarmi dove trovare documentazione su
SP1 e SP2 per Office 97 ?
Grazie anticipate e cordialità.
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi dado » 10/04/02 22:30

gianluigi ha scritto:Potresti indicarmi dove trovare documentazione su
SP1 e SP2 per Office 97 ?


Qui li trovi:

http://office.microsoft.com/downloads/d ... us|Updates

House: "Vede, tutti pensano che sia un paziente a causa del bastone"
Wilson: "Allora perchè non indossa un camice bianco come tutti noi?"
House: "Perchè altrimenti pensano che sia un medico".
Avatar utente
dado
Utente Senior
 
Post: 16208
Iscritto il: 21/08/01 01:00
Località: La Città dei Sette Assedi

Postdi JClark » 11/04/02 03:32

Grazie dado ... mi hai tolto d'impaccio :oops: , io li avevo trovati su delle riviste (se ben ricordo) ed avrei dovuto cercarli in rete a mia volta per poter rispondere :D
Il brutto tempo non esiste ... il brutto tempo è quello che passo senza andare in moto !

Bye Frank
:-)
JClark
Utente Senior
 
Post: 416
Iscritto il: 24/09/01 01:00
Località: Voghera

Postdi dado » 11/04/02 11:56

Figurati...!
A volte, perfino il sito della MS serve a qcosa!! :D :lol:

House: "Vede, tutti pensano che sia un paziente a causa del bastone"
Wilson: "Allora perchè non indossa un camice bianco come tutti noi?"
House: "Perchè altrimenti pensano che sia un medico".
Avatar utente
dado
Utente Senior
 
Post: 16208
Iscritto il: 21/08/01 01:00
Località: La Città dei Sette Assedi

Postdi gianluigi » 11/04/02 14:01

Ciao Dado
Grazie per la segnalazione.
Il Sito che mi hai indicato è veramente ricco di cose interessanti.
Purtroppo, evidentemente per mia colpa, non ho trovato notizie
utili a risolvere il mio problema.
Potresti darmi qualche ulteriore indicazione su cosa cercare?
Grazie anticipate.
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi Mikizo » 11/04/02 15:28

Come ha detto JClark, il problema si risolve con i Service Pack di Office 97 (se lo dice con sicurezza evidentemente lo sa!) quindi nella pagina che ti ha dato dado devi scaricarli e poi installarli.

Il nome che hanno nella pagina in questione non è proprio Service Pack ma Service Release, che poi è lo stesso.

Per farla semplicissima, clicca su download in corrispondenza di:
Office 97 Service Release 1 (SR-1) e
Office 97 Service Release 2b (SR-2b) Download Information

Anzi, io ti consiglierei di scaricare il secondo e installarlo, potrebbe bastare perchè è probabile che includa il primo.
Avatar utente
Mikizo
Download Admin
 
Post: 8517
Iscritto il: 05/01/02 01:00
Località: Outside

Postdi dado » 11/04/02 16:24

Se vuoi il link diretto al download, ricavabile cmq dalla pagina che ti ho indicato su, è:

http://office.microsoft.com/downloads/9 ... 97vpk.aspx

House: "Vede, tutti pensano che sia un paziente a causa del bastone"
Wilson: "Allora perchè non indossa un camice bianco come tutti noi?"
House: "Perchè altrimenti pensano che sia un medico".
Avatar utente
dado
Utente Senior
 
Post: 16208
Iscritto il: 21/08/01 01:00
Località: La Città dei Sette Assedi

Postdi gianluigi » 11/04/02 22:04

Ciao Mikizo
Grazie, grazie di cuore per la preziosa collaborazione
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Postdi gianluigi » 13/04/02 08:02

Sono felice di comunicarti che il mio Excel è ritornato
veloce come un fulmine.
Poichè io uso molto Excel, non puoi immaginarti la mia gioia.

Ho scaricato da Microsoft Italia la versione Italiana del
Service Release 1 (SR-1) di Office 97 (tempo: 1 ora e 10 min).
Installazione rapida e senza alcun problema (tempo : 2 min)

Poichè tutto funziona bene, non ho scaricato la Release SR2.

Nuovamente grazie di cuore.
gianluigi
Utente Junior
 
Post: 23
Iscritto il: 27/01/02 01:00
Località: Milano

Prossimo

Torna a Software Windows


Topic correlati a "EXCEL: Tempo di Chiusura dei Files eccessivamente lungo":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti