Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Risulataro = 0 se la somma viene < di 0 in Excel

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

Risulataro = 0 se la somma viene < di 0 in Excel

Postdi RunDLL » 04/06/04 09:26

Ciao a tutti e grazie per leggere il mio problema: prendiamo due celle in Excel, in una terza inserisco la formula per la somma o sottrazione (è indifferente) delle due celle iniziali. Ora vorrei che il risultato della somma o sottrazione delle due celle SE negativo, indipendentemente dal valore mi restituisse come risultato zero. Qualcuno mi sa dire coem dovrei fare? Grazie e tanti saluti
Avatar utente
RunDLL
Utente Senior
 
Post: 350
Iscritto il: 14/01/04 13:25

Sponsor
 

Postdi Garde » 04/06/04 09:36

La formula da inserire nella cella di somma potrebbe essere questa:
=SE(SOMMA(G2:G3)<0;0;SOMMA(G2:G3))
Non so se c'è un modo piu elegante
Ciao
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi RunDLL » 04/06/04 10:07

Funziona perfettamente grazie!!! :)
Avatar utente
RunDLL
Utente Senior
 
Post: 350
Iscritto il: 14/01/04 13:25

Postdi ezechiel2517 » 04/06/04 10:31

Garde ha scritto:La formula da inserire nella cella di somma potrebbe essere questa:
=SE(SOMMA(G2:G3)<0;0;SOMMA(G2:G3))
Non so se c'è un modo piu elegante


non so se e' + elegante, ma sicuramente una soluzione alternativa e'
=(A1+A2)*(A1>A2)
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi Garde » 04/06/04 10:42

Però se hai piu di due celle la faccenda si complica terribilmente.
Mentre con il "se" la formula e sempre la stessa qualunque numero di celle devi sommare. Basta cambiare i riferimenti.
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi ezechiel2517 » 04/06/04 11:34

Sicuro??? :)
=(somma(tutte le celle che vuoi))*(somma(tutte le celle che vuoi)>0)
;)
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi RunDLL » 04/06/04 11:53

=(A1+A2)*(A1>A2)


Ciao e grazie per la risposta. Io ho provato, non so se sbaglio io ma non mi funziona. Ho messo per provare i seguenti valori:

A1 ci ho messo 10
A2 ci ho messo -20
A3 la formula

Ma come risultato mi da -10 :eeh:

Invece con la formula di Garde funziona perfettamente. Ciao
Avatar utente
RunDLL
Utente Senior
 
Post: 350
Iscritto il: 14/01/04 13:25

Postdi ezechiel2517 » 04/06/04 12:12

hihihihihi :P
niente di sbagliato...se non la formula! ;)
questa va meglio:
=(A1+A2)*(A1+A2>0)

cmq l'ho scritta giusto per darti un alternativa, la formula con il SE e' quella che viene usata + frequentemente ;)
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi Garde » 04/06/04 18:18

Sicuro???
=(somma(tutte le celle che vuoi))*(somma(tutte le celle che vuoi)>0)

Oooops! :oops: :oops: :roll: :lol:
Garde
Utente Senior
 
Post: 220
Iscritto il: 21/01/04 10:35

Postdi ezechiel2517 » 05/06/04 16:59

Hihihihihi :D Dai non fare quella faccia... ;)
io in genere uso spesso la formuletta che ho suggerito come alternativa. Chiaro che e' utile solo nel caso si voglia avere 0 se le condizioni non sono soddisfatte! :P
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21


Torna a Software Windows


Topic correlati a "Risulataro = 0 se la somma viene < di 0 in Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti