Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media in excel

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

Media in excel

Postdi damianomx » 01/03/04 16:22

Per voi forse sarà banale, ma voglio far comparire in una cella di excel la media di valori presi da una serie di celle.
Fin qui nessun problema, basta un semplice =MEDIA(B30:B43), ma come faccio per far comparire un determinato testo in colonne dove non ci sono valori?
damianomx
Utente Senior
 
Post: 502
Iscritto il: 13/09/02 15:50
Località: Verona

Sponsor
 

Re: Media in excel

Postdi Sergio1983 » 01/03/04 16:29

damianomx ha scritto:ma come faccio per far comparire un determinato testo in colonne dove non ci sono valori?


Non ho capito... testo contenente che cosa?
E' meglio aver amato e perduto, piuttosto che non aver amato mai. (A. Tennyson)
Sergio1983
Utente Senior
 
Post: 2584
Iscritto il: 09/10/03 13:47
Località: Basso Piemonte

Postdi damianomx » 01/03/04 16:33

Ad esempio per una colonna dove non ci sono valori appare "N/A" o qualcosa del genere
damianomx
Utente Senior
 
Post: 502
Iscritto il: 13/09/02 15:50
Località: Verona

Postdi Sergio1983 » 01/03/04 16:45

Adesso ho capito, però ho provato con la formattazione condizionale, ma non trovo una condizione che permetta di fare ciò che vuoi tu...
E' meglio aver amato e perduto, piuttosto che non aver amato mai. (A. Tennyson)
Sergio1983
Utente Senior
 
Post: 2584
Iscritto il: 09/10/03 13:47
Località: Basso Piemonte

Postdi leonard » 02/03/04 10:12

Prova così: =media(b30:b43), nella cella C30 =SE(B30=0;"ATTENZIONE CELLA VUOTA";"")
leonard
Utente Junior
 
Post: 86
Iscritto il: 21/07/03 08:49
Località: cagliari

Postdi ezechiel2517 » 02/03/04 10:19

so ho ben capito devi fare la media di una colonna in cui non tutti i valori sono numerici.
prova con (supponendo i tuoi valori siano in B1:b19)
Codice: Seleziona tutto
=media(se(val.non.disp(B1:B19);B1:B19))
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi ezechiel2517 » 02/03/04 10:21

upps!! :oops:
esatto contrario :P
Codice: Seleziona tutto
=media(se(val.numero(B1:B19);B1:B19))
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi ezechiel2517 » 02/03/04 10:26

altrimenti se vuoi che la formula di tia la media se sono tutti numeri e un testo se c'e' un errore usa:
Codice: Seleziona tutto
=se(val.non.disp(media(B1:B19)); "TESTO A TUA SCELTA";media(B1:B19)); )
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi ezechiel2517 » 02/03/04 10:28

EDIT :diavolo:
Codice: Seleziona tutto
=se(val.non.disp(media(B1:B19));"TESTO A TUA SCELTA";media(B1:B19))
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi leonard » 02/03/04 11:05

Scusa Oracolo, ho provato ha usare la tua soluzione dove la media delle celle b1:b19 sono riuscito a ottenerla ma per il testo no.Vorrei,se non ti dispiace, capire la sintassi della tua formula.
Grazie
leonard
Utente Junior
 
Post: 86
Iscritto il: 21/07/03 08:49
Località: cagliari

Postdi leonard » 02/03/04 11:09

Ho fatto un pò di confusione con il tuo nome Ezechiel
scusami
leonard
Utente Junior
 
Post: 86
Iscritto il: 21/07/03 08:49
Località: cagliari

Postdi ezechiel2517 » 02/03/04 11:20

Hai office 2000?
non sei riuscito a ottenerla...perche' media non da mai errore a meno che non siano tutti valuri stringa! Ho appena provato e anche con
media(B1:b19)
ottengo sempre valori anche se inserisco delle stringhe :P
(qualcosa di buono alla MS lo fanno pure......questa e' una formula che uso da tempo immemore...non sapevo fosse del tutto inutile ora!)
In toeria la funzione SE funziona cosi:
SE(condizione; cosa fare se condizione=ver; cosa fare se condizione=falso)

quindi nella mia formula doveva venire fuori il testo se la media dava errore #NA e la media se questa non dava nessun errore.
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi leonard » 02/03/04 12:43

é vero la tua formula funziona benissimo, ma da quello che ho capito sembra che la comparsa del testo avvenga anche senza l'errore #ND
leonard
Utente Junior
 
Post: 86
Iscritto il: 21/07/03 08:49
Località: cagliari

Postdi ezechiel2517 » 02/03/04 14:06

non credo di aver capito! ;)

val.non.disp(valore) da vero solo se valore e' #NA
val.err(valore) da vero se valore e' un errore diverso da #NA
val.errore(valore) da vero per tutti i tipi di errore

con questi tre check puoi gestirti facilmente gli errori di excel (come le divisioni per zero per esempio!)
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21

Postdi leonard » 02/03/04 14:47

a questo punto Damianomx ha modo di provare la mia e la tua soluzione.Se poi non gli vanno bene nessuna delle due chieda :?: di cosa ha veramente bisogno
leonard
Utente Junior
 
Post: 86
Iscritto il: 21/07/03 08:49
Località: cagliari

Postdi damianomx » 02/03/04 19:23

Ezechiel, se uso l'ultima formula che mi hai dato il problema non si risolve, ci sono sempre gli errori nella media.
Ecco qui come si presenta la schermata:
Immagine
damianomx
Utente Senior
 
Post: 502
Iscritto il: 13/09/02 15:50
Località: Verona

Postdi ezechiel2517 » 02/03/04 19:41

ahhhhhhh...hai una divisione per 0!!!!
allora usa questa
Codice: Seleziona tutto
=se(val.err(media(B1:B19));"TESTO A TUA SCELTA";media(B1:B19))
ezechiel2517
Utente Senior
 
Post: 1598
Iscritto il: 05/04/02 20:21


Torna a Software Windows


Topic correlati a "Media in excel":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti